Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

nosampecontent runmode | AEM 6.3.3.3 | admin user not able to edit components on any page

Avatar

Avatar
Validate 1
Level 1
sujeet_singhr48
Level 1

Like

1 like

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
sujeet_singhr48
Level 1

Like

1 like

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
sujeet_singhr48
Level 1

24-06-2020

I am facing an issue on AEM 6.3 with nosamplecontent runmode (aka productionready mode).

 

Steps to reproduce issue:
1. Create a Vanilla AEM 6.3 Author Instance with nosamplecontent runmode.
2. Install Service Pack 6.3.3 on the instance.
3. Install CFP-3 to migrate the instance to 6.3.3.3 version.
4. Install Project Code or any sample site code on the instance.
5 Install relevant sample content.
6. Try to edit any component on the page using admin user.
 
Expectation: admin should be able to edit the component on the page.
 
Current behaviour: admin is not able to edit any components on the page.
 
Any help would be greatly appreciated. Thanks in advance.
 

 

AEM 6.3 nosamplecontent

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 5
Employee
vanegi
Employee

Likes

389 likes

Total Posts

377 posts

Correct Reply

147 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 50
View profile

Avatar
Give Back 5
Employee
vanegi
Employee

Likes

389 likes

Total Posts

377 posts

Correct Reply

147 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 50
View profile
vanegi
Employee

25-06-2020

Can you try below workaround and see if that helps?

 

- Go to package manager http://localhost:6333/crx/packmgr/index.jsp and reinstall packages :

core.wcm.components.content-1.0.0.zip

core.wcm.components.all-1.0.2.zip

Note: Version may be different.

- Recompile all JSPs ( http://localhost:6333/system/console/slingjsp )

OR

Restart the instance.

Answers (3)

Answers (3)

Avatar

Avatar
Validate 1
MVP
Theo_Pendle
MVP

Likes

237 likes

Total Posts

251 posts

Correct Reply

105 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 10
Ignite 1
View profile

Avatar
Validate 1
MVP
Theo_Pendle
MVP

Likes

237 likes

Total Posts

251 posts

Correct Reply

105 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 10
Ignite 1
View profile
Theo_Pendle
MVP

25-06-2020

Hello @sujeet_singhr48,

A few questions:

  1. Is the issue related to the nosamplecontent runmode or to the CFP3? What happens if you have
    1. 6.3.3.0 with nosamplecontent
    2. 6.3.3.3 with sample content
  2. Just to confirm, you are talking about an Authoring instance, correct?
  3. What are the "symptoms" exactly? Can you add a screenshot or GIF of an attempt to edit the content? For example:
    1. Can you select components or not?
    2. If so, what is stopping you from editing, do the editing options not appear in the toolbar?

Avatar

Avatar
Boost 1
Level 1
arpit_v
Level 1

Like

1 like

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
arpit_v
Level 1

Like

1 like

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
arpit_v
Level 1

24-06-2020

Hi @sujeet_singhr48 

Please validate:

  • the admin permission whether he has read/write access to corresponding content pages.
  • You mentioned only about admin user. Is it only happening for admin or all users?

If the above points is not the issue then it must be your custom code issue.please validate the JS console for any error and error.log if you can find any related error.

Avatar

Avatar
Affirm 50
MVP
Vaibhavi
MVP

Likes

216 likes

Total Posts

181 posts

Correct Reply

61 solutions
Top badges earned
Affirm 50
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Affirm 50
MVP
Vaibhavi
MVP

Likes

216 likes

Total Posts

181 posts

Correct Reply

61 solutions
Top badges earned
Affirm 50
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile
Vaibhavi
MVP

24-06-2020

Hi @sujeet_singhr48 , 

Ideally admin should have access for any modification by default. 

 

Can you please check the ACL permission for admin user and make sure read, write , edit ACLs are enabled. 

https://helpx.adobe.com/in/experience-manager/6-3/sites/administering/using/security.html