nosampecontent runmode | AEM 6.3.3.3 | admin user not able to edit components on any page

Avatar

Avatar

sujeet_singhr48

Avatar

sujeet_singhr48

sujeet_singhr48

24-06-2020

I am facing an issue on AEM 6.3 with nosamplecontent runmode (aka productionready mode).

 

Steps to reproduce issue:
1. Create a Vanilla AEM 6.3 Author Instance with nosamplecontent runmode.
2. Install Service Pack 6.3.3 on the instance.
3. Install CFP-3 to migrate the instance to 6.3.3.3 version.
4. Install Project Code or any sample site code on the instance.
5 Install relevant sample content.
6. Try to edit any component on the page using admin user.
 
Expectation: admin should be able to edit the component on the page.
 
Current behaviour: admin is not able to edit any components on the page.
 
Any help would be greatly appreciated. Thanks in advance.
 

 

AEM 6.3 nosamplecontent

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

vanegi

Employee

Avatar

vanegi

Employee

vanegi
Employee

25-06-2020

Can you try below workaround and see if that helps?

 

- Go to package manager http://localhost:6333/crx/packmgr/index.jsp and reinstall packages :

core.wcm.components.content-1.0.0.zip

core.wcm.components.all-1.0.2.zip

Note: Version may be different.

- Recompile all JSPs ( http://localhost:6333/system/console/slingjsp )

OR

Restart the instance.

Answers (3)

Answers (3)

Avatar

Avatar

Theo_Pendle

MVP

Avatar

Theo_Pendle

MVP

Theo_Pendle
MVP

25-06-2020

Hello @sujeet_singhr48,

A few questions:

  1. Is the issue related to the nosamplecontent runmode or to the CFP3? What happens if you have
    1. 6.3.3.0 with nosamplecontent
    2. 6.3.3.3 with sample content
  2. Just to confirm, you are talking about an Authoring instance, correct?
  3. What are the "symptoms" exactly? Can you add a screenshot or GIF of an attempt to edit the content? For example:
    1. Can you select components or not?
    2. If so, what is stopping you from editing, do the editing options not appear in the toolbar?

Avatar

Avatar

arpit_v

Avatar

arpit_v

arpit_v

24-06-2020

Hi @sujeet_singhr48 

Please validate:

  • the admin permission whether he has read/write access to corresponding content pages.
  • You mentioned only about admin user. Is it only happening for admin or all users?

If the above points is not the issue then it must be your custom code issue.please validate the JS console for any error and error.log if you can find any related error.

Avatar

Avatar

Vaibhavi

MVP

Avatar

Vaibhavi

MVP

Vaibhavi
MVP

24-06-2020

Hi @sujeet_singhr48 , 

Ideally admin should have access for any modification by default. 

 

Can you please check the ACL permission for admin user and make sure read, write , edit ACLs are enabled. 

https://helpx.adobe.com/in/experience-manager/6-3/sites/administering/using/security.html