NO components in AEM 6.4

qingtao

20-04-2020

I was trying to run the AEM 6.4.0 in my machine(Windows 10).  The AEM instance can be started but i am not able to see the components when edit the content page.  Anyone knows how to fix this?

 

BTW. I also tried on a iOS, it looks fine. 

component.jpg

Accepted Solutions (1)

Accepted Solutions (1)

BrianKasingli

MVP

20-04-2020

It looks like you are working on the Adobe's AEM WKND Project. You might be missing out the editable template's policies. You need to set some allowed components in the responsive grid component. Don't forget to unlock the component from the editable template after changes are made, so the JCR node's editable property is set to true (this allows authors to add components to the page).

By following this document, you would be able to go step by step on how to allow components for a specific editable template: https://docs.adobe.com/content/help/en/experience-manager-learn/getting-started-wknd-tutorial-develo...

If you are working with static templates, then it from the editable page, go into design mode; add allowed components in this section.

I hope this helps.

Answers (2)

Answers (2)

ankushb

Employee

20-04-2020

Do you see any warning/errors in the browser console when trying to load the components in the UI ?

I don't see any error in browser console. I can see an error in stdrr.log. 21.04.2020 10:05:52.527 *ERROR* [FelixStartLevel] ERROR: Bundle '544' Error starting jcrinstall:/apps/weretail/install/we.retail.core-3.0.0.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.sample.we.retail.core [544](R 544.0): missing requirement [com.adobe.cq.sample.we.retail.core [544](R 544.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.core.components.models)(version>=12.2.0)(!(version>=13.0.0))) Unresolved requirements: [[com.adobe.cq.sample.we.retail.core [544](R 544.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.core.components.models)(version>=12.2.0)(!(version>=13.0.0)))]) org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.sample.we.retail.core [544](R 544.0): missing requirement [com.adobe.cq.sample.we.retail.core [544](R 544.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.core.components.models)(version>=12.2.0)(!(version>=13.0.0))) Unresolved requirements: [[com.adobe.cq.sample.we.retail.core [544](R 544.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.core.components.models)(version>=12.2.0)(!(version>=13.0.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149) at org.apache.felix.framework.Felix.startBundle(Felix.java:2119) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:3
I did not genenerate the the ui.frontend model in WKND Tutorial

TUmesh

20-04-2020

Policy needs to be updated for that particular Template:

Steps:

1. click on Page Information( Mid option on the top left corner of the same page)

2. select Edit Template

3. on the template editor page click on the container layout box and select the policy icon.

4. From the left box's first drop down select one existing policy and save it.

5. else you can create a new one by writing name in the second box and select the component category from the right pan.

6. save and re-fresh the page

 

hope this will help.