Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

New CSS Changes not showing to all users on Chrome Desktop

Avatar

Avatar
Level 1
Elbie47
Level 1

Likes

0 likes

Total Posts

6 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
Elbie47
Level 1

Likes

0 likes

Total Posts

6 posts

Correct Reply

0 solutions
View profile
Elbie47
Level 1

25-06-2021

AEM 6.5 

On Premises

 

I am hoping someone has encountered similiar issue. We are picking up that after publishing changes, that some users are not seeing the latest CSS changes on Desktop Chrome. We first thought it is one user and specific to corporate PCs but the issue is showing more in general public viewers.

 

I recently encountered it myself on specific url page (PROD) clear my browser cache (all history) and then tested the change again but on our specific url page but in PREPROD and the issue remained. 

 

The line of code 2513 under clientlib-site.css was not showing up on my page. 

 

Screenshot 2021-06-18 at 17.47.04.pngScreenshot 2021-06-18 at 17.30.45.pngScreenshot 2021-06-25 at 13.30.52.png

 

Mobile Chrome, Safari Desktop and Safari Browser, Firefox no issues. 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 5
Level 6
Bhuwan_B
Level 6

Likes

132 likes

Total Posts

122 posts

Correct Reply

48 solutions
Top badges earned
Give Back 5
Boost 100
Give Back 3
Affirm 25
Establish
View profile

Avatar
Give Back 5
Level 6
Bhuwan_B
Level 6

Likes

132 likes

Total Posts

122 posts

Correct Reply

48 solutions
Top badges earned
Give Back 5
Boost 100
Give Back 3
Affirm 25
Establish
View profile
Bhuwan_B
Level 6

25-06-2021

@Elbie47 Please use versioned Clientlib to avoid mentioned issue, follow below URL for detailed steps to implement it.

https://www.initialyze.com/blog/2020/03/versioned-client-libraries-aem/

 

Answers (1)

Answers (1)

Avatar

Avatar
Boost 5
Level 7
Ritesh_M
Level 7

Likes

179 likes

Total Posts

142 posts

Correct Reply

44 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Boost 5
Level 7
Ritesh_M
Level 7

Likes

179 likes

Total Posts

142 posts

Correct Reply

44 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
Ritesh_M
Level 7

25-06-2021

Hi @Elbie47 ,

 

It looks like cache issue. May be the one of the publish server is still having old version of CSS cached which is not having below mentioned class. Do consider using appending hash value to the client library to have load latest css/js and avoid caching issue. 

 

 

You can use ACS AEM commons - Versioned ClientLibs

https://adobe-consulting-services.github.io/acs-aem-commons/features/versioned-clientlibs/index.html