mvn clean install -autoInstallPackage fails due Connection refused

Avatar

Avatar

tim-schwalbe-NZ

Avatar

tim-schwalbe-NZ

tim-schwalbe-NZ

29-01-2018

Hello, I am developing locally with an author instance only and it has always worked. But I think I deleted something in my instance and now it fails when I try to deploy the package. Is there any configuration to turn of deployment to publish? It looks strange that maven tries to deploy to http://localhost:4503/

It already tried a fresh AEM instance and it does also not work. I tried it for the last 4 hours and set everything up as far as I know.

Does the require a system user? I have deleted the user once and recreated it, but maybe I miss something.

Is there a maven or AEM config to solve this issue?

Thanks and regards!

[INFO] --- content-package-maven-plugin:0.0.23:install (install-package) @ test-com-relaunch.apps ---

[INFO] Installing test-com-relaunch.apps (C:\dev\projects\test\test-com-new\test-com-relaunch\apps\target\test-com-relaunch.apps-1.0.0-SNAPSHOT.zip) to http://localhost:4503/crx/packmgr/service.jsp [INFO] HttpMethodDirector - I/O exception (java.net.ConnectException) caught when processing request: Connection refused: connect

[INFO] HttpMethodDirector - Retrying request

[INFO] HttpMethodDirector - I/O exception (java.net.ConnectException) caught when processing request: Connection refused: connect

[INFO] HttpMethodDirector - Retrying request [INFO] HttpMethodDirector - I/O exception (java.net.ConnectException) caught when processing request: Connection refused: connect

[INFO] HttpMethodDirector - Retrying request

ERROR] Failed to execute goal com.day.jcr.vault:content-package-maven-plugin:0.0.23:install (install-package) on project test-com-relaunch.apps: Connection refused: connect -> [Help 1]

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

tim-schwalbe-NZ

Avatar

tim-schwalbe-NZ

tim-schwalbe-NZ

29-01-2018

Okay I got it now. It was a wrong config in the parent pom...

Answers (2)

Answers (2)

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

11-07-2018

See this -- it shows building an AEM Project successfully via Maven Archetype 13....

Avatar

Avatar

RamMeeran728687

Avatar

RamMeeran728687

RamMeeran728687

11-07-2018

Could you please tell me what configuration has given in parent POM? I am also facing the same error. Thanks !!