Highlighted

Multiple issues after upgrading to CFP17

Avatar

Avatar

MikolajBuda

Avatar

MikolajBuda

MikolajBuda

04-11-2018

Hi!

I've recently upgraded AEM 6.2 SP1 CFP 14 with the latest CFP 17. After upgrading and restarting AEM editor mode is not responsive. I'm not able to edit/add components or even use header's coral panel.

Another found issue is: portals' cloud configurations are not listed on miscadmin#/etc/cloudservices on author mode thus I'm not able to activate any changes.

Are there any prerequisites needed when switching from CFP 14 to the latest one? I've not found any relevant information in release notes.

Replies

Highlighted

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

961

Correct Answer

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

961

Correct Answer

1.1K
kautuk_sahni
Community Manager

05-11-2018

Do make sure:

1. Applying CFP without validating compatibility between installed feature packs may result in system failure or loss of custom configurations, which could require restoration from backup to resolve.

2. For AEM Forms customers, it is essential to install AEM Forms add-on package after installing any AEM Service Pack, Cumulative Fix Pack, or Feature Pack.

Please share Error.log.

-Kautuk

Highlighted

Avatar

Avatar

kjaeggin

Employee

Avatar

kjaeggin

Employee

kjaeggin
Employee

05-11-2018

Is this JEE, or OSGi only?

Highlighted

Avatar

Avatar

MikolajBuda

Avatar

MikolajBuda

MikolajBuda

06-11-2018

Validating content package

4 unsatisfied OSGi package imports in 1 bundle.

1. Unsatisfied package import twitter4j.json-[3.0.5,4.0.0) in bundle com.adobe.acs.acs-aem-commons-bundle-twitter-3.9.0 present at OSGi

2. Unsatisfied package import twitter4j-[3.0.5,4.0.0) in bundle com.adobe.acs.acs-aem-commons-bundle-twitter-3.9.0 present at OSGi

3. Unsatisfied package import twitter4j.conf-[3.0.5,4.0.0) in bundle com.adobe.acs.acs-aem-commons-bundle-twitter-3.9.0 present at OSGi

4. Unsatisfied package import twitter4j.auth-[3.0.5,4.0.0) in bundle com.adobe.acs.acs-aem-commons-bundle-twitter-3.9.0 present at OSGi

Following 1 bundle will go from 'Active' to 'Installed' state if you install this content package.

1. com.adobe.acs.acs-aem-commons-bundle-twitter-3.9.0

4 unsatisfied OSGi package imports. No overlay rebase warnings. No ACL warnings.


It doesn't seem to be a problem. And we don't use AEM Forms here.

Please take a look on attached error log. It contains logs starting from CFP17 installation and ending on opening any page in editor.html mode:https://ufile.io/pxfq6

After some investigation it seems that JS error is present during page loading in edit mode:

core.js:2682 Uncaught TypeError: ns.getSegments is not a function

    at Object.getProperty (core.js:2682)

    at Array.ns.components.self._findAllowedComponentsFromDesign (core.js:24814)

    at Array.ns.components.self.computeAllowedComponents (core.js:24859)

    at core.js:24913

    at Array.forEach (<anonymous>)

    at HTMLDocument.<anonymous> (core.js:24911)

    at HTMLDocument.dispatch (jquery.js:5226)

    at HTMLDocument.elemData.handle (jquery.js:4878)

    at Object.trigger (jquery.js:5130)

    at HTMLDocument.<anonymous> (jquery.js:5860)

The line of code:

var nodeContentsForAll = getNodeContentsForAllMatchingPaths(ns.getSegments(editableConfig), designs, propertyName);

File affected: /libs/cq/gui/components/authoring/editors/clientlibs/core.js

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

06-11-2018

There seems to be a bug here. Please open a support ticket.