Moving a page to rename, but AEM reverts the name back to original

Avatar

Avatar
Level 1
pduncan
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
pduncan
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
pduncan
Level 1

26-05-2020

I am trying to rename a page by using the move function and changing the 'name' field. When I change the name, click 'Next', the 'Move' button is greyed out. 

When I click back, the name still appears as changed. But I am unable to proceed. 

I tested moving the page to another location and the name didn't change. 

How do I fix this issue? I've renamed pages using this method before with no issues. 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 4
raghavc
Level 4

Likes

63 likes

Total Posts

61 posts

Correct reply

19 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back
Boost 50
View profile

Avatar
Validate 1
Level 4
raghavc
Level 4

Likes

63 likes

Total Posts

61 posts

Correct reply

19 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back
Boost 50
View profile
raghavc
Level 4

27-05-2020

@pduncan please confirm the AEM version you are using.

 

When you try to move a AEM page , the move button will be disabled if the path does not allow the template of the page you are moving to be a child of the page under which you are moving. You would face this issue even if you are moving under the same parent path, if the allowed templates definition of the parent page was changed after the child page was initially created. 

 

 

Answers (2)

Answers (2)

Avatar

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
Vish_dhaliwal
Employee

27-05-2020

There were few known bugs with page move/rename feature.

The issues are now resolved in 6.4.8 and 6.5.4. Make sure you test with the latest service packs.

Regards,

Vishu

Avatar

Avatar
Establish
MVP
BrianKasingli
MVP

Likes

645 likes

Total Posts

607 posts

Correct reply

239 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Establish
MVP
BrianKasingli
MVP

Likes

645 likes

Total Posts

607 posts

Correct reply

239 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
BrianKasingli
MVP

27-05-2020

@pduncan,

Do you have any custom Workflow launchers enabled? or services like JCR listeners enabled? Maybe automated tasks are adding strange behaviours when pages are renamed, within your AEM instance.

Can you replicate this in a fresh AEM instance on startup, with sample content? let's try to understand if this is the AEM product, or your custom code itself.