Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Metadata Schemas - Related Assets in Properties

Avatar

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
geoffg59889438
Level 1

01-10-2018

Hi there,

I'm building a custom Metadata Schema form to include links to related assets (Metadata Schemas ). However, when an asset is related to another (i.e. source, derived, others), the related asset does not appear as a link in the asset properties. When I try to unrelate the asset, I receive a prompt of removing the related asset - proof that the relation is indeed established.

I've tried building the form using the following components:

- Asset Referenced By

- Asset Referencing

- Read-Only link

None of the above components in the metadata schema form seem to show the related asset in the properties.

I appreciate the help!

Replies

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

03-10-2018

Hi Geo

  What is the version of AEM ?

Thanks

Veena

Avatar

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
geoffg59889438
Level 1

03-10-2018

AEM 6.3

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

03-10-2018

Okay . So I am testing this out now. I was doing it in 6.2 now but will check in 6.3 . In 6.2 I got the asset referenced as links

1585804_pastedImage_0.png

Let me test this out in 6.3 and update you

Thanks

Veena

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

03-10-2018

Hi geo

  Tested this in 6.3 . I am able to get the referenced pages as links. PFB the screenshot

1585942_pastedImage_0.png

Please check and let me know if this is what you are having issue with ?

Avatar

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
geoffg59889438
Level 1

03-10-2018

Thank you Veena,

The reference links appear for references to collections. However, links do not appear for relations to other assets (e.g. source, derived, others).

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

03-10-2018

Oh .. Okay .. Got you .. How can I replicate the scenario for testing ?

Avatar

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
geoffg59889438
Level 1

03-10-2018

- duplicated the default metadata schema (with a new name, let's say "test_duplicate").

- made some modifications to the schema, such as removing redundant fields.

- applied the new schema to a folder, and added assets.

- related an asset to another in the properties panel - as a "Source"

- related another asset in the properties panel - as "other"

- relation links do not appear in the asset properties.

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

03-10-2018

Thanks . I tested this scenario also and seems like it is working fine for me

1587052_pastedImage_0.png

1587056_pastedImage_1.png

  I have installed SP2 in my 6.3 server . Do you think that could be an issue for you ?

Avatar

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
geoffg59889438
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
geoffg59889438
Level 1

03-10-2018

Yes, I believe SP2 is installed. Here is a screenshot of what I'm seeing.

You'll noticed that 2 related assets exist, but the links are not populating.

AEM Assets   Asset Metadata (3).png