Metadata Schema Default values .

vijayl12137971

11-02-2019

Hi All ,

I am using Drop Down Predicate in the metadata build form and I have setup with the values Yes and No. Now I have defaulted to the value Yes for that drop down. 
When I apply the current schema to any asset or folder, I do not see any default values on the crxde when I checked the properties.
If I go to that asset metadata schema , And if I click SAVE option without making any changes then only I am able to see default values for the Drop down on the crx/de.

I am using AEM 6.2 CFP 18

Thanks.

Accepted Solutions (0)

Answers (5)

Answers (5)

Gaurav-Behl

MVP

11-02-2019

My assumption is that when you click SAVE, it unlocks and syncs your changes with the schema which doesn't happen on CLOSE especially the sync piece.

You may check for the lock icon on the default/custom schema that you try to modify. It must show as locked on CLOSE but unlocked on SAVE (when it syncs the new added/deleted properties)

vijayl12137971

11-02-2019

Thanks Gaurav for Replying.

In the (screen shot 2) as you can see the newly added schema.  I haven't made any changes on the rest of the schema and also my schema anyways defaulted to a value (Yes) so I have clicked CLOSE instead of SAVE option . And now  My expectation is to see that property on the CRXDE, No matter how many times you do the refresh or reload  it doesn't show the property.

If I go back and click save option even though I haven't changed anything on the schema and then If I do a refresh on the CRXDE then I am able to see the property.

Lets say , if there are 1000 assets  it is highly impossible to individually save each asset to show the defaulted property on the CRXDE

Thanks

Gaurav-Behl

MVP

11-02-2019

Are you saying that you've to do an explicit refresh in /crx/de for that node/property to get the latest updated value (as mentioned in step 4 & 5)?

To me, that's the default behavior of /crx/de because you're viewing a stale session value when other thread can update that value, you have to refresh it.

vijayl12137971

11-02-2019

  1. Under the tools -> Assets -> Metadata Schema -> Default

http://localhost:4502/mnt/overlay/dam/gui/content/metadataschemaeditor/schemadetails.html/default?fo...

  1. I have added Drop Down with options  Yes and No to the OOTB form (Screen shot 1)
  2. I have checked if the newly added drop down with the default  option Yes is showing on the assets or not ,and it is showing as expected on UI (Screen shot 2)
  3. I checked properties on the CRXDE for the asset there I do not see that property being stored (Screen shot 3)
  4. Now I have saved without making any changes  on the schema of that asset .(screen shot 4)
  5. Then I did a refresh on the CRXDE then I was able to see property being stored for that asset (screen shot 5).

Final-doc.png


Thanks.