Maven dependency for uber-jar does not find its version

Avatar

Avatar
Validate 10
Level 2
salvadorm142499
Level 2

Likes

3 likes

Total Posts

36 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 2
salvadorm142499
Level 2

Likes

3 likes

Total Posts

36 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile
salvadorm142499
Level 2

15-09-2016

Hi all,

I have created a new project by using Eclipse+AEM Plugin for AEM 6.2 based on a multi-module project whose archetype is: aem project archetype 10.

Then, I have removed this dependency:

            <dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>aem-api</artifactId>
                <version>6.0.0.1</version>
                <scope>provided</scope>
            </dependency>

And, following the link https://docs.adobe.com/docs/en/aem/6-2/develop/dev-tools/ht-projects-maven.html, I have added this:

    
<dependency>
    <groupId>com.adobe.aem</groupId>
    <artifactId>uber-jar</artifactId>
    <version>6.2.0</version>
    <classifier>apis</classifier>
    <scope>provided</scope>
</dependency>

 

After building my project, I get this error:

[ERROR] Some problems were encountered while processing the POMs:

[ERROR] 'dependencies.dependency.version' for com.adobe.aem:uber-jar:jar is missing. @ com.myproject:aem-bundle-core:[unknown-version]

 

Does anybody know what I am missing?

 

Thanks, Salvador.

View Entire Topic

Avatar

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
manish_anand
Level 3

25-10-2018

Hi,

I am trying to add uber 6.3.2.2, but it says missing dependency. But when i add "<classifier>obfuscated-apis</classifier>", it works fine

Can you please tell me why this classifier is required? Will it be a problem for me later?