Manifest.MF is not full generating, bundle is not getting installed

Avatar

Avatar

s1101v

Avatar

s1101v

s1101v

28-02-2021

Hello All - I am running into issues with deploying/installing the bundle. I generated the maven project using the latest version 23. While installing the bundle via maven, I am getting this "is not an OSGi Bundle, not uploading". I have verified the MANIFEST.MF file and it has all the information for the bundle, but if I open the generated jar file, I couldn't see all the required info. I see only "Manifest-Version: 1.0,Build-Jdk-Spec: 1.8,Created-By: Maven Archiver 3.4.0". 

 

Because of the above issue, the bundle is not getting installed. I have tried many possible options but no luck. Could someone help with this?

-----------------------------------------

[INFO] --- maven-compiler-plugin:3.8.1:testCompile (default-testCompile) @ product-inventory.core ---

[INFO] No sources to compile
[INFO]
[INFO] --- maven-surefire-plugin:2.22.1:test (default-test) @ product-inventory.core ---
[INFO] No tests to run.
[INFO]
[INFO] --- maven-jar-plugin:3.1.2:jar (default-jar) @ product-inventory.core ---
[INFO] Building jar: C:\Users\IdeaProjects\product-inventory\core\target\product-inventory.core-1.0-SNAPSHOT.jar
[INFO]
[INFO] --- bnd-baseline-maven-plugin:4.2.0:baseline (baseline) @ product-inventory.core ---
[INFO] Determining the baseline version for com.test.product:product-inventory.core:jar:(,1.0-SNAPSHOT) using repositories [artifactory (http://repo1.test.com/artifactory/repo, default, releases+snapshots)]
Downloading: http://repo1.test.com/artifactory/repo/com/test/product/product-inventory.core/maven-metadata.xml
[INFO] The baseline version was found to be null
[WARNING] No previous version of com.test.product:product-inventory.core:jar:1.0-SNAPSHOT could be found to baseline against
[INFO]
[INFO] --- maven-install-plugin:2.5.2:install (default-install) @ product-inventory.core ---
[INFO] Installing C:\Users\IdeaProjects\product-inventory\core\target\product-inventory.core-1.0-SNAPSHOT.jar to C:\Users\.m2\repo1\m3-3.3.9\com\test\product\product-inventory.core\1.0-SNAPSHOT\product-inventory.core-1.0-SNAPSHOT.jar
[INFO] Installing C:\Users\IdeaProjects\product-inventory\core\pom.xml to C:\Users\.m2\repo1\m3-3.3.9\com\test\product\product-inventory.core\1.0-SNAPSHOT\product-inventory.core-1.0-SNAPSHOT.pom
[INFO]
[INFO] --- maven-sling-plugin:2.1.0:install (install-bundle) @ product-inventory.core ---
[INFO] C:\Users\IdeaProjects\product-inventory\core\target\product-inventory.core-1.0-SNAPSHOT.jar is not an OSGi Bundle, not uploading
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 19.859 s
[INFO] Final Memory: 35M/247M
[INFO] ------------------------------------------------------------------------

 

-----------------------------------

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

SureshDhulipudi

MVP

Avatar

SureshDhulipudi

MVP

SureshDhulipudi
MVP

01-03-2021

you can mark it as accepted solution

 

Hello All - This has been fixed. I had to recreate the project and it worked. I might have removed some of the section from core pom.

Answers (0)