Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Magento Commerce Enabled AEM 6.5.7 clientlibs not loading

Avatar

Avatar
Establish
Level 1
anupammaiti
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Establish
Validate 1
View profile

Avatar
Establish
Level 1
anupammaiti
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Establish
Validate 1
View profile
anupammaiti
Level 1

11-05-2021

AEM Archetype 27, Commerce enabled Integrated with Magento. Followed the below documentation  to configure

https://experienceleague.adobe.com/docs/experience-manager-65/commerce/storefront/getting-started.ht...

AEM Details : AEM 6.5

Service Pack :6.5.7

Commerce Add-on : commerce-addon-aem-650-all

Facing below issue 

 

1. Clientlibs are not loading in AEM storefront.Screenshot 2021-05-12 at 12.40.26 AM.png

 

2. Getting error in console :Resource at '/magento/graphql' not found: No resource found.

Screenshot 2021-05-12 at 12.42.44 AM.png

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

112 likes

Total Posts

394 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

112 likes

Total Posts

394 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile
Prince_Shivhare
Level 7

12-05-2021

Hi @anupammaiti ,

 

I don't think there is a relation between clientlib and /graphql endpoint.

Setting up the CIF add-on project won't affect the clientlib.

 it should load properly. can you please confirm if you are getting this issue in the author or publisher environment?

can you try hitting http://localhost:4502/commerce.html and see if you are able to see the products.

if not then configuration in cloud service is not done properly.

 

when you are giving localhost:4502/magento/graphql then make sure you have proxied the magento endpoint to localhost:4502.

thanks,

Prince

Answers (2)

Answers (2)

Avatar

Avatar
Give Back 10
MVP
shelly-goel
MVP

Likes

180 likes

Total Posts

338 posts

Correct Reply

88 solutions
Top badges earned
Give Back 10
Validate 1
Shape 1
Ignite 1
Give Back 5
View profile

Avatar
Give Back 10
MVP
shelly-goel
MVP

Likes

180 likes

Total Posts

338 posts

Correct Reply

88 solutions
Top badges earned
Give Back 10
Validate 1
Shape 1
Ignite 1
Give Back 5
View profile
shelly-goel
MVP

11-05-2021

Looks like local proxy is not setup

https://github.com/adobe/aem-cif-guides-venia

Avatar

Avatar
Affirm 50
MVP
Vaibhavi
MVP

Likes

216 likes

Total Posts

181 posts

Correct Reply

61 solutions
Top badges earned
Affirm 50
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Affirm 50
MVP
Vaibhavi
MVP

Likes

216 likes

Total Posts

181 posts

Correct Reply

61 solutions
Top badges earned
Affirm 50
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile
Vaibhavi
MVP

11-05-2021

Hi @anupammaiti , 

Seems like permission issue. 

Please have a check if permission (read ACL) is enabled for /magento/graphql and /etc folder folder.

Also please have a check on dispatcher filter is not blocking the request. 

 

https://experienceleague.adobe.com/docs/experience-manager-65/administering/security/security.html?l...