Links are changed when loaded into dialog

erical90264454

27-03-2020

Hi,

When authoring links with special characters those links are then changed when I open the dialog again. 

Special character such as '&' are escaped to '&.'.

The fields in question are pathfield and pagefield. 

Please help me locate where this is done cause we can't open a dialog without ruining all the links within.

 

example : http://www.example.com/page.html?value1=hello&value2=hi  -->http://www.example.com/page.html?value1=hello&value2=hi

AEM 6.4.6, it starts failing after installing aem-service-pkg-6.4.6.

 

Thank in advance!

Erica

Accepted Solutions (1)

Accepted Solutions (1)

BrianKasingli

MVP

28-03-2020

Hi @erical90264454,

I've tested out your situation, and I'm not able to replicate your problem. 

 

Test: I've configured both the pathfield and pagepath input fields with the value of "http://www.example.com/page.html?value1=hello&value2=hi". Tested on latest FireFox, Chrome, Safari.


When I reconfigure the input fields, the Expected is: http://www.example.com/page.html?value1=hello&value2=hi


When I reconfigure the input fields, the Actual is: 
http://www.example.com/page.html?value1=hello&value2=hi

 

Summary: The set value is not altered, and the Touch UI dialogue is working as expected.

 

Dialogue Setup:

<pathfield
    jcr:primaryType="nt:unstructured"
    sling:resourceType="granite/ui/components/coral/foundation/form/pathfield"
    fieldLabel="Path Field"
    name="./pathfield"
    rootPath="/content"/>
<pagefield
    jcr:primaryType="nt:unstructured"
    sling:resourceType="cq/gui/components/coral/common/form/pagefield"
    fieldLabel="Page Field"
    name="./pagefield"
    rootPath="/content"/>

 @erical90264454 What browser are you using?

Answers (0)