Highlighted

JCR Read issues

Arun_007

25-11-2017

Hi All,

In my application, i have a Dialog created to edit the properties of the page. Using the dialog we display the jcr properties and allow the authors to edit the properties as well. It was working fine before.

And suddenly, whenever the dialog loads it loads empty, even though the jcr-content properties are present. In the dialog, when any field is added with the new value, its getting reflected in the jcr nodes at the backend.

We were on version AEM 6.1 SP2 before and we recently installed the CFP11. Am not sure what would have caused this weird issue. Can someone help me on how to troubleshoot this issue and is there any possible configuration causing this issue.?

Replies

Highlighted

Arun_007

27-11-2017

Hi,

We were not seeing any errors. This was working fine with SP2 whithout CFP11. This read issue is occuring only on CFP11. Is there any configuration change which could resolve these? we could able to write succesfully into JCR but couldn't able to read from JCR content.

Highlighted

Jörg_Hoh

Employee

27-11-2017

Please use your browser debugging tools and check the responses of the JSON requests populating the dialog fields.

Jörg

Highlighted

Arun_007

28-11-2017

Thanks much for your time to write back for this post.

Yes I tried prior to writing this post itself. Unfortunately they do not return the JCR nodes in the JCR content response itself. It was purely a CFP11 issue. I was looking for anyone with same issue on AEM 6.1 SP2 CFP11 has resolved this using any workarounds?

Thanks

Arun.

Highlighted

Jörg_Hoh

Employee

28-11-2017

If you assume that it is a problem with CFP 11 (and you can reproduce it on different instances too) I would strongly recommend to raise a support ticket for it.

Jörg