javax.inject,version=[0.0,1) — Cannot be resolved

Avatar

Avatar

Var

Avatar

Var

Var

09-04-2017

Is there any other work around to fix the javax.inject,version=[0.0,1) -- Cannot be resolvedissue in OSGI bundle.

I have tried all the approaches provided in the below forum. but still my bundle doesn't resolve.

I am using AEM 6.2 + Java version: 1.8.0_121 + Apache Maven 3.3.9 and archetypeVersion=10 

http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

The POC code snippet can be found in my drive here

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Feike_Visser1

Employee

Avatar

Feike_Visser1

Employee

Feike_Visser1
Employee

10-04-2017

add this dependency:

        <dependency>

            <groupId>javax.inject</groupId>

            <artifactId>javax.inject</artifactId>

            <version>1</version>

            <scope>provided</scope>

        </dependency>

Answers (4)

Answers (4)

Avatar

Avatar

vjetty

Avatar

vjetty

vjetty

09-04-2017

Hi, Try these dependencies.

<dependency> <groupId>org.apache.sling</groupId> <artifactId>org.apache.sling.models.api</artifactId> <version>1.2.2</version> <scope>provided</scope> </dependency> <dependency> <groupId>org.apache.sling</groupId> <artifactId>org.apache.sling.models.impl</artifactId> <version>1.2.2</version> <scope>provided</scope> </dependency> <dependency> <groupId>org.apache.geronimo.specs</groupId> <artifactId>geronimo-atinject_1.0_spec</artifactId> <version>1.0</version> <scope>provided</scope> </dependency>

And also check the required uber-jar is present.

<dependency> <groupId>com.adobe.aem</groupId> <artifactId>uber-jar</artifactId> <version>6.2.0</version> <classifier>apis</classifier> <scope>provided</scope> </dependency>

Hope this helps!

Thanks,

Vamsi

Avatar

Avatar

Abhishek_jha65-

Avatar

Abhishek_jha65-

Abhishek_jha65-

23-07-2017

It's working!

Avatar

Avatar

Var

Avatar

Var

Var

10-04-2017

Feike Visser wrote...

add this dependency:

        <dependency>

            <groupId>javax.inject</groupId>

            <artifactId>javax.inject</artifactId>

            <version>1</version>

            <scope>provided</scope>

        </dependency>

 

Thanks Feike,

after so many rebuilds with modification of pom files finally found it works with

<dependency><groupId>org.apache.sling</groupId><artifactId>o‌​rg.apache.sling.mode‌​ls.api</artifactId><‌​/dependency> <dependency> <groupId>org.apache.sling</groupId> <artifactId>org.apache.sling.models.impl</artifactId> </dependency> <dependency> <groupId>javax.inject</groupId> <artifactId>javax.inject</artifactId> </dependency>

 as mandatory in build and remaining uber-jar and geronimo-atinject_1.0_spec jars as optional. even both together works.

Avatar

Avatar

Prince_Shivhare

Avatar

Prince_Shivhare

Prince_Shivhare

10-04-2017

Hi,

This issue is only in AEM 6.2 once you create or deploy new project. you need to add the below dependency in your core project:

<dependency> <groupId>javax.inject</groupId> <artifactId>javax.inject</artifactId> <version>1</version> </dependency>

AEM versions prior to 6.2, there was a dependency to javax.inject version 0 whereas now they need version 1 and that's not reflected in the pom.xml.

 

~ Prince