java.lang.IllegalArgumentException: Invalid token ''

Avatar

Avatar

sai111

Avatar

sai111

sai111

14-10-2019

On AEM login seeing exception java.lang.IllegalArgumentException: Invalid token '' can someone please help(It is existing 6.3 sp2 instance no upgrade is done), is there any possibility I can recover it

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

19-10-2019

Today i too faced this issue in my local instance and i was able to resolve this  after following below steps-

1. Deleted launchpad folder

2. Start the server

3. Delete cookies from the browser or close the browser and try to access the server

4. Able to login to the server

Answers (11)

Answers (11)

Avatar

Avatar

sai111

Avatar

sai111

sai111

22-10-2019

Hi ka786...Thanks for the response

In my case deleting launchpad did not work, and it stopped loading the instance unfortunately....deleting few of the bundles partially worked to get the instance back

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

15-10-2019

Hope you were able to resolve this..

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

14-10-2019

Please check the logs.

If you are seeing segment not found then follow steps given in below link to fix that issue-

Fix Inconsistencies in the repository when SegmentNotFound Issue is reported in AEM 6.x

Avatar

Avatar

sai111

Avatar

sai111

sai111

14-10-2019

Instance startup stopped I believe I can see few folders came up in launchpad folder ..it is at the same point as 2 hours back not starting

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

14-10-2019

It will take time keep monitoring the bundles under launchpad folder..

Avatar

Avatar

sai111

Avatar

sai111

sai111

14-10-2019

It is taking so long to load and start after deletion of launchpad folder..will it take some time or something is wrong ..

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

14-10-2019

Try deleting launchpad folder-

crx-quickstart\launchpad

and restart the server.

Avatar

Avatar

sai111

Avatar

sai111

sai111

14-10-2019

I am not able to open any of the consoles now , it is only throwing that exception on every console, is there anything else I should do to have a successful login

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

14-10-2019

Could u pls have a look at this thread as well-

How to close user session after 30 minutes of inactivity In AEM 6.1

Specifically this one-

  • Also make sure to set Token Length otherwise will throw exception "org.eclipse.jetty.servlet.ServletHandler / java.lang.IllegalArgumentException: Invalid token ''"

Avatar

Avatar

sai111

Avatar

sai111

sai111

14-10-2019

Tried restarting using bin/start but did not work for me ...cleared cookies nd tried logging in but still did not help...

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

14-10-2019