java.lang.IllegalArgumentException: Invalid token ''

sai111

14-10-2019

On AEM login seeing exception java.lang.IllegalArgumentException: Invalid token '' can someone please help(It is existing 6.3 sp2 instance no upgrade is done), is there any possibility I can recover it

Accepted Solutions (1)

Accepted Solutions (1)

Ankur_Khare

MVP

19-10-2019

Today i too faced this issue in my local instance and i was able to resolve this  after following below steps-

1. Deleted launchpad folder

2. Start the server

3. Delete cookies from the browser or close the browser and try to access the server

4. Able to login to the server

Answers (11)

Answers (11)

sai111

22-10-2019

Hi ka786...Thanks for the response

In my case deleting launchpad did not work, and it stopped loading the instance unfortunately....deleting few of the bundles partially worked to get the instance back

sai111

14-10-2019

Instance startup stopped I believe I can see few folders came up in launchpad folder ..it is at the same point as 2 hours back not starting

sai111

14-10-2019

I am not able to open any of the consoles now , it is only throwing that exception on every console, is there anything else I should do to have a successful login

Ankur_Khare

MVP

14-10-2019

Could u pls have a look at this thread as well-

How to close user session after 30 minutes of inactivity In AEM 6.1

Specifically this one-

  • Also make sure to set Token Length otherwise will throw exception "org.eclipse.jetty.servlet.ServletHandler / java.lang.IllegalArgumentException: Invalid token ''"