Issues with appResourcesPath

Avatar

Avatar
Validate 1
Level 1
aemninja
Level 1

Likes

2 likes

Total Posts

59 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
aemninja
Level 1

Likes

2 likes

Total Posts

59 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
aemninja
Level 1

11-04-2021

Hello All - I am facing an issues with displaying the favicon. Currently based on appResourcesPath, I am loading the favicon image. The image is getting displayed in author, publish and but not in direct URL (dispatcher/CDN). Can someone tell me what could be the issue?

 

${page.appResourcesPath}

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Applaud 25
Level 10
asutosh_jena
Level 10

Likes

593 likes

Total Posts

705 posts

Correct reply

207 solutions
Top badges earned
Applaud 25
Give Back 100
Boost 500
Affirm 100
Ignite 1
View profile

Avatar
Applaud 25
Level 10
asutosh_jena
Level 10

Likes

593 likes

Total Posts

705 posts

Correct reply

207 solutions
Top badges earned
Applaud 25
Give Back 100
Boost 500
Affirm 100
Ignite 1
View profile
asutosh_jena
Level 10

11-04-2021

Hi @aemninja 

If it's accessible in publish instance then it's not an code issue and it's limited to dispatcher configuration only.

You will need to see what is the path that is requested to load the favicon and if the path is allowed in the farm file on the dispatcher /filter section

Also you can check in th dispatcher.log what error you are getting when you are trying to access the file directly. This will help you in debug the issue and you will be able to find the RC.

www.something.com/favicon.ico or www.something.com/something/something/favicon.ico

 

 

Thanks!

Answers (0)