Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Issue WithCqedditconfig

Avatar

Level 4

Hi Team,

We are facing an issue while using cq:editconfig node.

If we use cq:editconfig node for any component & then we use that component on any page as follows-

1.Dragged and dropped component on to the page.-component1

2.Added one more component below this component which doesn't have cq:Editconfig node.-component2

3..Added one more component below this component which doesn't have cq:Editconfig node.-component3

4.Now when i try to drag and drop the component3 above  with component1 not able to do show it comes as follows-

 

Not able to understand what is the issue.

It works fine if we don't use cq:editconfig for the component.

Could someone help on this.

Regards

2 Replies

Avatar

Level 10

Can you share screenshot of what you seen when you drag and drop component3 with component 1

Also share configurations in editConfig.

Avatar

Level 4

Hi,

PFA the screen shot for the error while moving component2 on top of component 1 & also PFA the screen shot for dialog properties which are causing issue.

If i remove cq:actions properties and just keep it as empty , issues gets resolved but ifwe are adding properties issues comes up.

Avatar

Community Advisor

Hi Ankur,

This is the known issue for AEM6.1. You can find in third point under SITES. Copy and Move options won't work properly. If you remove cq:actions property, it will work. 

Known issues for AEM 6.1: https://docs.adobe.com/docs/en/aem/6-1/release-notes/known-issues.html


SITES

  • Page Properties: Bulk edit doesn't work in Microsoft Internet Explorer 11. Please use other browser. (CQ-42070)
  • Page Authoring: An error is thrown when trying to edit a component that is included in a component and it not yet present in the jcr:content of the page. Make sure the template adds the resources when the page is created (CQ-36949)
  • Page Authoring: cq:actions are not properly parsed - "copymove" action not working (CQ-40917)
  • Page Authoring: Edit mobile site in 'Adaptive Mobile Editor' is not supported in Touch-optimized UI. Please use the Classic UI (CQ-18198)
  • Page Authoring: Extension point for the header bar in Page Authoring is broken (CQ-41697)
  • Launches: Promote Launch from editor.html does not work if server is running on context path (CQ-42046)
  • MSM: Suspendng or stopping a background rollout will end with exception (CQ-17743)

Might be it has been resolved in AEM6.2: https://docs.adobe.com/docs/en/aem/6-2/release-notes/known-issues.html

Hope this helps!!

Thanks,
Ratna Kumar.