Issue while upgrading from AEM 6.3 TO 6.5

Avatar

Avatar
Validate 10
Level 3
Shallu_Rohilla
Level 3

Likes

8 likes

Total Posts

69 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
Shallu_Rohilla
Level 3

Likes

8 likes

Total Posts

69 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
Shallu_Rohilla
Level 3

22-05-2020

Hi,

We are doing AEM upgrade from version 6.3 to 6.5. Also moving from Jboss to Tomcat.(AEM 6.5 author is on Tomcat). While starting up the server, we are getting this exception:

22.05.2020 02:30:08.686 *ERROR* [FelixDispatchQueue] org.apache.sling.startupfilter.disabler FrameworkEvent ERROR (org.osgi.framework.BundleException:
Unable to resolve org.apache.sling.startupfilter.disabler [146](R 146.0):
missing requirement [org.apache.sling.startupfilter.disabler [146](R 146.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve org.apache.sling.startupfilter [52](R 52.1):
missing requirement [org.apache.sling.startupfilter [52](R 52.1)] osgi.wiring.package;
(&(osgi.wiring.package=javax.servlet)(version>=3.1.0)(!(version>=4.0.0)))] Unresolved requirements:
[[org.apache.sling.startupfilter.disabler [146](R 146.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.startupfilter.disabler [146](R 146.0):
missing requirement [org.apache.sling.startupfilter.disabler [146](R 146.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)))
[caused by: Unable to resolve org.apache.sling.startupfilter [52](R 52.1): missing requirement
[org.apache.sling.startupfilter [52](R 52.1)] osgi.wiring.package; (&(osgi.wiring.package=javax.servlet)(version>=3.1.0)
(!(version>=4.0.0)))] Unresolved requirements: [[org.apache.sling.startupfilter.disabler [146](R 146.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)

 

Any help would be appreciated.

 

Just to add we tried this : https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/aem-6-2-and-java-1-8/qaq-p...

We couldn't find any such property in sling.properties.

Regards,

Shallu Rohilla

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 2
gspatil11
Level 2

Likes

3 likes

Total Posts

14 posts

Correct reply

1 solution
Top badges earned
Validate 1
Give Back
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
gspatil11
Level 2

Likes

3 likes

Total Posts

14 posts

Correct reply

1 solution
Top badges earned
Validate 1
Give Back
Boost 3
Boost 1
Affirm 1
View profile
gspatil11
Level 2

28-05-2020

We have changed tomcat attribute: strictServletCompliance as false and that has resolved the issue with javax.servlet version>=3.1.0. We are using javax.servlet version:3.0 now on same Tomcat instance.

Answers (2)

Answers (2)

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,141 likes

Total Posts

3,167 posts

Correct reply

1,084 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,141 likes

Total Posts

3,167 posts

Correct reply

1,084 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

22-05-2020

 

Hi,

 

the problem is:

(&(osgi.wiring.package=javax.servlet)(version>=3.1.0)(!(version>=4.0.0)))]

 

what version of Tomcat do you use? 

 

From what I see in the specification at https://tomcat.apache.org/whichversion.html, only Tomcat 8.0.x and 8.5 are eligible, as any newer version brings javax.servlet 4.0 specification (which is not supported according to this version range). And according to the support matrix at https://helpx.adobe.com/experience-manager/6-3/sites/deploying/using/technical-requirements.html only Tomcat 8.5 is supported.

 

Avatar

Avatar
Validate 1
MVP
ArpitVarshney
MVP

Likes

136 likes

Total Posts

185 posts

Correct reply

36 solutions
Top badges earned
Validate 1
Establish
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Validate 1
MVP
ArpitVarshney
MVP

Likes

136 likes

Total Posts

185 posts

Correct reply

36 solutions
Top badges earned
Validate 1
Establish
Give Back 5
Give Back 3
Give Back 25
View profile
ArpitVarshney
MVP

22-05-2020

Hi @Shallu_Rohilla 

 

Can you try installing the latest service pack of AEM 6.5? 

I've recently upgraded AEM 6.3 to AEM 6.5.4 and didn't face any such issue.

 

Also please confirm:

  • Are you doing an in-place upgrade or moving the content over packages?
  • is this issue happening after installing the your custom code?

 

Regards,

Arpit Varshney