Highlighted

Issue in opening dialog pop in content fragment

deepak112CTS

05-09-2018

Hi All,

I have a dialog pop up in content fragment. When I click the dialog pop up icon I can see below error in console in chrome dev tool.

1564983_pastedImage_0.png

Replies

Highlighted

deepak112CTS

05-09-2018

Hi,

I just created a fragment from my model.

Its opening dialog on clicking og tick mark in text box.

Its working fine in other environment but in stage env its not opening. We dont have any custom code for fragment form so we are using everything out of box.

foundation.js:3684 Uncaught TypeError: Cannot read property 'attach' of undefined

    at HTMLElement.Prototype._showPicker (foundation.js:3684)

    at foundation.js:3655

    at jquery.js:3411

    at fire (jquery.js:3232)

    at Object.fireWith [as resolveWith] (jquery.js:3362)

    at jquery.js:3418

    at fire (jquery.js:3232)

    at Object.fireWith [as resolveWith] (jquery.js:3362)

    at deferred.(anonymous function) (https://author-bristolmyerssquibb-aem64-stg.adobecqms.net/etc.clientlibs/clientlibs/granite/jquery.j...)

    at fire (jquery.js:3232)

Prototype._showPicker @ foundation.js:3684

(anonymous) @ foundation.js:3655

(anonymous) @ jquery.js:3411

fire @ jquery.js:3232

fireWith @ jquery.js:3362

(anonymous) @ jquery.js:3418

fire @ jquery.js:3232

fireWith @ jquery.js:3362

deferred.(anonymous function) @ jquery.js:3461

fire @ jquery.js:3232

add @ jquery.js:3291

(anonymous) @ jquery.js:3415

fire @ jquery.js:3232

fireWith @ jquery.js:3362

done @ jquery.js:9840

callback @ jquery.js:10311

XMLHttpRequest.send (async)

XMLHttpRequest.send @ granite.js:269

send @ jquery.js:10254

ajax @ jquery.js:9738

resolveElement @ foundation.js:2968

Prototype._loadAndShowPicker @ foundation.js:3651

Prototype._togglePicker @ foundation.js:3676

(anonymous) @ foundation.js:3094

Please let me know if you need any further details.

Thanks

Highlighted
Highlighted
Highlighted
Highlighted

pradeepn6086740

16-01-2019

Hi All,

In case if anybody is checking for the fix for this. Please update the "Source VM" and "Target VM" configs in "Apache Sling Java Script Handler" configuration to auto.

Thanks,

Pradeep