I am trying to overlay createpagewizard

Avatar

Avatar

AEMnewbie

Avatar

AEMnewbie

AEMnewbie

20-01-2021

Screen Shot 2021-01-20 at 5.23.28 PM.pngScreen Shot 2021-01-20 at 5.25.06 PM.pngI am trying to hide the tags from the createpagewizard. The one i have highlighted in the screenshot. I was able to accomplish that ..But i notice some weird behavior after making that change .. For existing page components the edit tool which we notice in the edit mode isnt visible. Am i missing something? which is causing this awkward behavior

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

BrianKasingli

MVP

Avatar

BrianKasingli

MVP

BrianKasingli
MVP

20-01-2021

@AEMnewbie,

In most parts, page templates use the sling:superResourceType of /libs/foundation/components/page, which registers a dialogue with all the default options using Sling Resource Merger; this is why you don't see the nodes that make up the dialogue configurations. To remove the unwanted fields, in particular the tab_basic fields, you must overlay the tab_basic JCR node, /libs/foundation/components/page/tab_basic, in your /apps/my-site/ folder. 

Screenshot 2021-01-20 at 13.09.10.png

I hope this helps. 

 

 

Answers (2)

Answers (2)

Avatar

Avatar

Arun_Patidar

MVP

Total Posts

3.1K

Likes

1.2K

Correct Reply

883

Avatar

Arun_Patidar

MVP

Total Posts

3.1K

Likes

1.2K

Correct Reply

883
Arun_Patidar
MVP

21-01-2021

This happened when you don't overlay node properly:

  1. created a cq:dialog node in your page component /apps/myproj/components/structure/defaultpage/cq:dialog/content/items/tabs/items/basic
  2. create tabs node(nt:unstructured) at /apps/myproj/components/structure/defaultpage/tabs/basic/items/column/items/title/items/tags with overlay node
  3. add basic tab created in step2 in the page dialog node(Step1) using path property 
    path
    String

    /apps/myproj/components/structure/defaultpage/tabs/basic

Avatar

Avatar

KiranVedantam1992

Avatar

KiranVedantam1992

KiranVedantam1992

20-01-2021

Hi @AEMnewbie,

 

Can you please let me know the following:

  1. Any error is shown in the console after page load
  2. Any error is shown in the error.log related to the page after page load
  3. The XML that you have modified is not broken/invalid
  4. Try clearing the browser cache - some times this can also cause the issue

If you check the above things, you might find the root cause of the issue which can help us get the fix.

 

Thanks,

Kiran Vedantam.