How to remove the wcmmode=disabled in Web URL?

Avatar

Avatar

Ted2007277

Avatar

Ted2007277

Ted2007277

19-03-2021

Website URL:

Screen Shot 2021-03-19 at 3.57.03 PM 6.png

 

Below is my code in the component of Free Html Content Area,

<style>
/* 適用於電腦螢幕*/
@mediascreen{
#motion-1{
width:120rem;
height: 90rem;
}
}
@mediascreen and (min-width:1920px) and (max-width:2018px){
#motion-1{
width:112rem;
height: 72rem;
}
}
/* 適用於筆電*/
@mediascreen and (min-width:1481px) and (max-width:1919px){
#motion-1{
width:85rem;
height: 55rem;
}
}
@mediascreen and (min-width:1367px) and (max-width:1480px){
#motion-1{
width:80rem;
height: 55rem;
}
}
/* 適用於平版直著拿的情況(平版橫著拿的情況就和電腦螢幕相同)*/
@mediascreen and (min-width:1080px) and (max-width:1366px){
#motion-1{
width:65rem;
height: 35rem;
}
}
@mediascreen and (min-width:992px) and (max-width:1079px){
#motion-1{
width:45rem;
height: 30rem;
}
}
/* 適用於平版直著拿的情況(平版橫著拿的情況就和電腦螢幕相同)*/
@mediascreen and (min-width:840px) and (max-width:992px){
#motion-1{
width:60rem;
height: 36rem;
}
}
@mediascreen and (min-width:600px) and (max-width:839px){
#motion-1{
width:56rem;
height: 32rem;
}
}
/* 適用於平版直著拿的情況(平版橫著拿的情況就和電腦螢幕相同)*/
@mediascreen and (min-width:375px) and (max-width:599px){
#motion-1{
display: none;
}
}
</style>
<script src="https://unpkg.com/@lottiefiles/lottie-player@latest/dist/lottie-player.js"></script>
<lottie-player src="https://assets8.lottiefiles.com/private_files/lf30_lzybfnbn.json" id="motion-1" background="transparent" speed="1" style="z-index:1;" loop autoplay></lottie-player>

<script>
var oDiv1=document.getElementById("motion-1");

if (/(iPhone|iPad|iPod|iOS|Android)/i.test(navigator.userAgent)) {
//手機裝置
oDiv1.style.display="none";
}else{
oDiv1.style.display="block";
}
</script>

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

BrianKasingli

MVP

Avatar

BrianKasingli

MVP

BrianKasingli
MVP

19-03-2021

@Ted2007277,

If you are in your publish environment, it might be because a developer has hardcoded ?wcmmode=disabled to be appended on to the target URI or link. ?wcmmode=disabled is actually never automatically appended to a target URI or link by AEM out of the box, so it might be done by a developer. Currently, only using the AEM site's edit mode, you can only access ?wcmmode=disabled when you hit the "view publish mode" from the drop-down options; "view publish mode" have been clicked on, the URI will be changed to a new URI + ?wcmmode=disabled

I would say to search for our source code for ?wcmmode=disabled

Answers (1)

Answers (1)

Avatar

Avatar

Rohit_Utreja

Avatar

Rohit_Utreja

Rohit_Utreja

19-03-2021

Are you adding it manually on your own?
if this is the case, you can go to editor mode by adding "editor.html" before the content in the URL and switch to preview mode.

 

If this is happening in the publisher environment, then the source of this URL needs to be checked. There is a possibility that the source URL has this keyword mentioned in it.