Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

How to create osgi bundle on the 64-bit windows OS

Avatar

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile
bbboy2014
Level 2

15-10-2015

Hi there,

I had ever create bundles on the 32-bit OS successfully. Today i use the maven 3.2.3 to create osgi bundles on the 64-bit OS, but always appear error like below:

E:\sling>mvn archetype:generate -DarchetypeGroupId=com.day.jcr.vault -DarchetypeArtifactId=multimodule-content-package-archetype -DarchetypeVersion=1.0.0 -DarchetypeRepository=adobe-public-releases -e [INFO] Error stacktraces are turned on. [INFO] Scanning for projects... Downloading: http://repo.adobe.com/nexus/content/groups/public/org/codehaus/mojo/maven-metadata.xml Downloading: http://repo.adobe.com/nexus/content/groups/public/org/apache/maven/plugins/maven-metadata.xml [WARNING] Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to adobe (http://repo.adobe.com/nexus/content/groups/public/): java.lang.RuntimeException: Could not generate DH keypair [WARNING] Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to adobe (http://repo.adobe.com/nexus/content/groups/public/): java.lang.RuntimeException: Could not generate DH keypair Downloading: http://repo.adobe.com/nexus/content/groups/public/org/apache/maven/plugins/maven-archetype-plugin/ma... [WARNING] Could not transfer metadata org.apache.maven.plugins:maven-archetype-plugin/maven-metadata.xml from/to adobe (http://repo.adobe.com/nexus/content/groups/public/): java.lang.RuntimeException: Could not generate DH keypair [INFO] [INFO] ------------------------------------------------------------------------ [INFO] Building Maven Stub Project (No POM) 1 [INFO] ------------------------------------------------------------------------ [WARNING] Failure to transfer org.apache.maven.plugins/maven-metadata.xml from http://repo.adobe.com/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of adobe has elapsed or updates are forced. Original error: Could not transfer metadata org.apache.maven.plugins/maven-metadata.xml from/to adobe (http://repo.adobe.com/nexu s/content/groups/public/): java.lang.RuntimeException: Could not generate DH keypair [WARNING] Failure to transfer org.codehaus.mojo/maven-metadata.xml from http://repo.adobe.com/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of adobe has elapsed or updates are forced. Original error: Could not transfer metadata org.codehaus.mojo/maven-metadata.xml from/to adobe (http://repo.adobe.com/nexus/content/grou ps/public/): java.lang.RuntimeException: Could not generate DH keypair [WARNING] Failure to transfer org.apache.maven.plugins:maven-archetype-plugin/maven-metadata.xml from http://repo.adobe.com/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of adobe has elapsed or updates are forced. Original error: Could not transfer metadata org.apache.maven.plugins:maven-archetype-plugin/maven-metadata .xml from/to adobe (http://repo.adobe.com/nexus/content/groups/public/): java.lang.RuntimeException: Could not generate DH keypair [INFO] [INFO] >>> maven-archetype-plugin:2.3:generate (default-cli) > generate-sources @ standalone-pom >>> [INFO] [INFO] <<< maven-archetype-plugin:2.3:generate (default-cli) < generate-sources @ standalone-pom <<< [INFO] [INFO] --- maven-archetype-plugin:2.3:generate (default-cli) @ standalone-pom --- [INFO] Generating project in Interactive mode [INFO] Archetype defined by properties Downloading: http://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/multimodule-content-package-arch... [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 5.940 s [INFO] Finished at: 2015-05-06T18:04:53-07:00 [INFO] Final Memory: 11M/120M [INFO] ------------------------------------------------------------------------ [ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2.3:generate (default-cli) on project standalone-pom: The desired archetype does not exist (com.day.jcr.vault:multimodule -content-package-archetype:1.0.0) -> [Help 1] org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2.3:generate (default-cli) on project standalone-pom: The desired archety pe does not exist (com.day.jcr.vault:multimodule-content-package-archetype:1.0.0) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80) at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:120) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:347) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:154) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:582) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:214) at org.apache.maven.cli.MavenCli.main(MavenCli.java:158) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289) at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415) at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356) Caused by: org.apache.maven.plugin.MojoFailureException: The desired archetype does not exist (com.day.jcr.vault:multimodule-content-package-archetype:1.0.0) at org.apache.maven.archetype.mojos.CreateProjectFromArchetypeMojo.execute(CreateProjectFromArchetypeMojo.java:205) at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:132) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208) ... 19 more Caused by: org.apache.maven.archetype.exception.UnknownArchetype: The desired archetype does not exist (com.day.jcr.vault:multimodule-content-package-archetype:1.0.0) at org.apache.maven.archetype.ui.generation.DefaultArchetypeGenerationConfigurator.configureArchetype(DefaultArchetypeGenerationConfigurator.java:119) at org.apache.maven.archetype.mojos.CreateProjectFromArchetypeMojo.execute(CreateProjectFromArchetypeMojo.java:189) ... 21 more [ERROR] [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException E:\sling>

And the java version information below:

E:\sling>java -version java version "1.6.0_45" Java(TM) SE Runtime Environment (build 1.6.0_45-b06) Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)

And file {M3_HOME}\conf\settings.xml profile like below:

<profile> <id>adobe-public</id> <activation> <activeByDefault>true</activeByDefault> </activation> <repositories> <repository> <id>adobe</id> <name>Nexus Proxy Repository</name> <url>http://repo.adobe.com/nexus/content/groups/public/</url> <layout>default</layout> </repository> </repositories> <pluginRepositories> <pluginRepository> <id>adobe</id> <name>Nexus Proxy Repository</name> <url>http://repo.adobe.com/nexus/content/groups/public/</url> <layout>default</layout> </pluginRepository> </pluginRepositories> </profile>

BTW, refer to this article https://helpx.adobe.com/experience-manager/using/first-osgi.html

Anyone know how to deal with this problem? I had ever try this example  OS windows7 32-bit on my computer, it run very well. But this time failure always since changed 64-bit OS.

 

Thanks a lot in advance.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,118 likes

Total Posts

3,149 posts

Correct Reply

1,073 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,118 likes

Total Posts

3,149 posts

Correct Reply

1,073 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

15-10-2015

Hi,

please update your java to a more recent version. When you google the error message, you find statements which indicate that there is a limitation inside the JVM, which make the SSL handshake fail under certain circumstances. Looks like you hit one of these.

On the other hand: Free support for Java 1.6 has been ended by Oracle some time ago, and even the free support of Java 1.7 has ended these days. So update at least to Java 1.7 if you run your AEM with that version.

kind regards,
Jörg

Answers (7)

Answers (7)

Avatar

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile
bbboy2014
Level 2

15-10-2015

Thank you Jörg very much. And i want to learn more from you. How do you find this problem is related to Java version? Could you told me something more?

Avatar

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile
bbboy2014
Level 2

15-10-2015

E:\sling>java -version
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)

Avatar

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile
bbboy2014
Level 2

15-10-2015

hi, i just try did it, but not work and failure as always.

Avatar

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 10
Level 2
bbboy2014
Level 2

Like

1 like

Total Posts

150 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
Affirm 1
View profile
bbboy2014
Level 2

15-10-2015

Exactly, i just refer to this article to create OSGI bundle as you mention here, but always failure only because i reinstall windows OS 64-bit on my computer, instead of 32-bit OS.

Avatar

Avatar
Validate 25
Level 3
vdhim23
Level 3

Like

1 like

Total Posts

135 posts

Correct Reply

9 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile

Avatar
Validate 25
Level 3
vdhim23
Level 3

Like

1 like

Total Posts

135 posts

Correct Reply

9 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Ignite 5
Ignite 3
View profile
vdhim23
Level 3

15-10-2015

<profile> <id>adobe-public</id> <activation> <activeByDefault>true</activeByDefault> </activation> <properties> <releaseRepository-Id>adobe-public-releases</releaseRepository-Id> <releaseRepository-Name>Adobe Public Releases</releaseRepository-Name> <releaseRepository-URL>http://repo.adobe.com/nexus/content/groups/public1</releaseRepository-URL> </properties> <repositories> <repository> <id>adobe-public-releases</id> <name>Adobe Basel Public Repository</name> <url>https://repo.adobe.com/nexus/content/groups/public</url> <releases> <enabled>true</enabled> <updatePolicy>never</updatePolicy> </releases> <snapshots> <enabled>false</enabled> </snapshots> </repository> </repositories> <pluginRepositories> <pluginRepository> <id>adobe-public-releases</id> <name>Adobe Basel Public Repository</name> <url>http://repo.adobe.com/nexus/content/groups/public3</url> <releases> <enabled>true</enabled> <updatePolicy>never</updatePolicy> </releases> <snapshots> <enabled>false</enabled> </snapshots> </pluginRepository> </pluginRepositories> </profile>

Try to add this profile in settings.xml

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,118 likes

Total Posts

3,149 posts

Correct Reply

1,073 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,118 likes

Total Posts

3,149 posts

Correct Reply

1,073 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

15-10-2015

Hi

looks like this is a JVM problem. Can you share which version you are using? Just type "java -version" and post the results here.

kind regards,
Jörg

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

15-10-2015

There are no issues in building OSGi bundles on Win64. Ensure Maven is setup. See

https://helpx.adobe.com/experience-manager/using/first-osgi.html