getting org.apache.sling.models.annotations,version=[1.5,2) -- Cannot be resolved while installing osgi bundle in aem 6.3

nehacms-0r3f0r

28-06-2017

Hi,

While following helpx article:

Developing your first Experience Manager 6.3 Components

after importing the package into aem 6.3 instance. Getting below error in the OSGI Bundle.

getting org.apache.sling.models.annotations,version=[1.5,2) -- Cannot be resolved

Attaching the screenshot as well.

1239511_pastedImage_2.png

Does aem needs some other version than what is available in pom.xml. Pom.xml has below dependency being used:

<dependency>

                <groupId>biz.aQute.bnd</groupId>

                <artifactId>annotation</artifactId>

                <version>2.4.0</version>

                <scope>provided</scope>

            </dependency>

Thanks,

Neha

Accepted Solutions (1)

Accepted Solutions (1)

Ratna_Kumar

MVP

28-06-2017

Hi,

Yes Jorg is absolutely correct. I have re-tested the article and AEM 6.3 comes with the version 1.4.0 in Sling models annotation. Below is the screenshot for the same.

SlingModel1.PNG

Hope this helps!

~Ratna.

Answers (5)

Answers (5)

nehacms-0r3f0r

30-06-2017

Thanks all for update.

Issue got resolved by updating dependency for:

<dependency>

            <groupId>org.apache.sling</groupId>

            <artifactId>org.apache.sling.models.api</artifactId>

            <version>1.3.2</version>

        </dependency>

in pom.xml. Earlier I had placed version 1.3.4 which was causing issue.   

Jörg_Hoh

Employee

28-06-2017

Hi,

AEM 6.3 comes with org.apache.sling.models.annotations in version 1.4.0. (exported by Bundle Sling Models API version 1.3.2). Your project obviously compiles against a newer version of the Sling Models bundle. Please check your dependencies.

Jörg