Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Getting error while building angular SPA with AEM 6.5 project

Avatar

Avatar
Validate 1
MVP
santhosh_kumark
MVP

Likes

98 likes

Total Posts

111 posts

Correct Reply

38 solutions
Top badges earned
Validate 1
Give Back 3
Give Back
Boost 50
Boost 5
View profile

Avatar
Validate 1
MVP
santhosh_kumark
MVP

Likes

98 likes

Total Posts

111 posts

Correct Reply

38 solutions
Top badges earned
Validate 1
Give Back 3
Give Back
Boost 50
Boost 5
View profile
santhosh_kumark
MVP

28-10-2020

Hi,

 

I am getting error while building angular SPA with AEM 6.5 project both from eclipse and cmd prompt.

Error:

Failed to execute goal com.github.eirslett:frontend-maven-plugin:1.6:install-node-and-npm (install node and npm) on project spa-angular-app: Could not download Node.js from: https://nodejs.org/dist/v11.2.0/win-x64/node.exe: Could not download https://nodejs.org/dist/v11.2.0/win-x64/node.exe: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 1]

santhosh_kumark_0-1603898003480.png

I tried adding vm parameters "-Djavax.net.ssl.trustStore" also, but it doesn't work. Can anyone help with this.

 

Regards,

Santosh

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 3
prashantonkar
Level 3

Likes

17 likes

Total Posts

51 posts

Correct Reply

7 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 3
prashantonkar
Level 3

Likes

17 likes

Total Posts

51 posts

Correct Reply

7 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
prashantonkar
Level 3

09-11-2020

As an alternative, install node and npm manually and run the following commands in the same order.

In ui.frontend

npm install

npm run build

In ui.apps

mvn clean install -PautoInstallPackage.

It will push both your Angular code as well as AEM code.

Answers (3)

Answers (3)

Avatar

Avatar
Establish
MVP
Anudeep_Garnepudi
MVP

Likes

271 likes

Total Posts

320 posts

Correct Reply

87 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Establish
MVP
Anudeep_Garnepudi
MVP

Likes

271 likes

Total Posts

320 posts

Correct Reply

87 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
Anudeep_Garnepudi
MVP

10-11-2020

Hi @santhosh_kumark 

Try updating your Java version. If you are currently running Java 8, update to latest Java 8 version that is available. Hope this may resolve your issue.

AG

Avatar

Avatar
Establish
MVP
Anudeep_Garnepudi
MVP

Likes

271 likes

Total Posts

320 posts

Correct Reply

87 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Establish
MVP
Anudeep_Garnepudi
MVP

Likes

271 likes

Total Posts

320 posts

Correct Reply

87 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
Anudeep_Garnepudi
MVP

29-10-2020

Hi @santhosh_kumark 

Node 11.2.0 installed in your system? If not try installing it manually and set PATH. If it is already installed refer the below link and try.

https://stackoverflow.com/questions/21076179/pkix-path-building-failed-and-unable-to-find-valid-cert...

Hope this will help.

AG

Avatar

Avatar
Validate 1
MVP
Umesh_Thakur
MVP

Likes

135 likes

Total Posts

146 posts

Correct Reply

49 solutions
Top badges earned
Validate 1
Applaud 25
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
MVP
Umesh_Thakur
MVP

Likes

135 likes

Total Posts

146 posts

Correct Reply

49 solutions
Top badges earned
Validate 1
Applaud 25
Ignite 3
Ignite 1
Give Back 5
View profile
Umesh_Thakur
MVP

28-10-2020

Hi @santhosh_kumark ,

It seems your maven repo is trying to connect with https remote repo and there it is failing, it seems like you will have to make some changes at the settings.xml see the below post https://stackoverflow.com/questions/25911623/problems-using-maven-and-ssl-behind-proxy

I think this will help.

Umesh Thakur