Frequent Logout in AEM Environment.

Avatar

Avatar

tushaar_srivastava

Avatar

tushaar_srivastava

tushaar_srivastava

15-07-2019

Hi,

I am facing frequent Logout issue in my development environment :4502

Scenario: whenever I sign in into Dev environment user: admin ; password: admin, and in between working my instance get automatically Logout.

So,please suggest me How to stop this frequent Logout until we click on Logout button.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

cal-netsolution

Avatar

cal-netsolution

cal-netsolution

15-07-2019

Hi Tushar, you can go to OSGI configuration, http://localhost:4502/system/console/configMgr and search for Apache jackrabbit oak TokenConfiguration. The Token expiration should have default value as 43200000 milliseconds, i.e. 12 hours (This suggests that AEM logout after inactivity of 12 hours). Check in you case if anything has been modified in this field.

If this helped, pls mark it as 'helpful'

Answers (7)

Answers (7)

Avatar

Avatar

BrijeshYadav

Avatar

BrijeshYadav

BrijeshYadav

16-07-2019

Hi Tushar,

You can open crx/de and delete configuration node at  /apps/system/config/org.apache.jackrabbit.oak.security.authentication.token.TokenConfigurationImpl.config.

Restart aem and it will reset it to default configuration values.

1792862_pastedImage_1.png

Avatar

Avatar

anujg3325839

Avatar

anujg3325839

anujg3325839

15-07-2019

You want to reset the hash algo if the config is not taking effect.

for this [0]  configuration

[0] http://host:port/system/console/configMgr/org.apache.jackrabbit.oak.security.authentication.token.To...

open and click on reset button. This will reset the hash algo. and restart the AEM environment.

also please refer to the - How to set the Oak login token session expiration

Avatar

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

996

Correct Reply

1.0K

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

996

Correct Reply

1.0K
Jörg_Hoh
Employee

15-07-2019

That's a strange behavior indeed. Have you tried a different browser already? Just to eliminate the chance that a faulty browser plugin kills your cookies.

Avatar

Avatar

alexaj563593

Avatar

alexaj563593

alexaj563593

15-07-2019

Ya I'm also having same problem with me while doing my assignment thank you for your help.

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K
kautuk_sahni
Community Manager

15-07-2019

Are you seeing this on fresh instance Or is this happening after some custom deployment?

Do you see error in error.log? Which AEM version are you on? Also, are you having multiple AEM instance open in same browser (not sure if this is Bug, but something happend with me 1.5 years back | it is like connecting to AEM with several users in the same browser tabs: the switch between the different tabs cannot work because i assume they all share the same session, aka the authentication cookie.)?

@Joerg Hoh Any inputs?

Avatar

Avatar

cal-netsolution

Avatar

cal-netsolution

cal-netsolution

15-07-2019

Can you try restarting your dev instance, as per my experience before, if we do any changes to Apache jackrabbit oak TokenConfiguration it will show authentication failed message.

After restart it should work properly,and the value you have edited 43200000 should be saved. Also check your error logs if you see any other error. If the issue still persists, please do check the error logs, what kind of error it is throwing. And one more thing what was the value of the Token expiration before you have edited it?

Avatar

Avatar

tushaar_srivastava

Avatar

tushaar_srivastava

tushaar_srivastava

15-07-2019

Thanks, but even after applying the above property I still My Dev environment automatically get logged-out

1791636_pastedImage_0.png

I am getting this after Dev loggout,

1791637_pastedImage_1.png