Form is not getting submitted in dispatcher

Avatar

Avatar
Contributor 2
Level 4
Dinu_Arya
Level 4

Likes

38 likes

Total Posts

184 posts

Correct reply

16 solutions
Top badges earned
Contributor 2
Applaud 25
Validate 50
Validate 25
Validate 10
View profile

Avatar
Contributor 2
Level 4
Dinu_Arya
Level 4

Likes

38 likes

Total Posts

184 posts

Correct reply

16 solutions
Top badges earned
Contributor 2
Applaud 25
Validate 50
Validate 25
Validate 10
View profile
Dinu_Arya
Level 4

29-04-2017

Hi Team,

We have created AEM forms and they are getting submitted successfully in publish but not in dispatcher.

In dispatcher while submitting the form, we are getting the below alert -

[AF] [AEM-AF-901-004]: Encountered an internal error while submitting the form

On click of submit button we observed the below call in Network tab -

/content/forms/af/<myproject>/<myforms>/<myform>/jcr:content/guideContainer.af.internalsubmit.jsp

Please let me know do I need to change any configuration in the dispatcher.

Thanks,

AryA.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 3
puradawid
Level 3

Likes

12 likes

Total Posts

31 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
puradawid
Level 3

Likes

12 likes

Total Posts

31 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
puradawid
Level 3

30-04-2017

Hey AryA, to be honest:

  1. hard to tell what is your dispatcher configuration
  2. are you getting 404 during this call to that JSP? Is it fine, HTTP OK 200, any other response code? Any content in response?

Some of dispatchers (I am not 100% sure but the default one seems to be done well) are configured to not handle jcr:content (to response with 404 or even worse).

Answers (4)

Answers (4)

Avatar

Avatar
Level 1
leep67941422
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
leep67941422
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile
leep67941422
Level 1

17-03-2021

We have the same issue using AEM 6.5 if you try directly on publish all is well but on dispatcher we get a 400 error on the following  /jcr:content/guideContainer.af.internalsubmit.jsp.

 

Even though this thread says there is an answer I don't see one.

Avatar

Avatar
Validate 10
Level 3
srikanthp689160
Level 3

Likes

20 likes

Total Posts

95 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
srikanthp689160
Level 3

Likes

20 likes

Total Posts

95 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
srikanthp689160
Level 3

21-02-2018

Hi,

Were you able to resolve this issue?

If yes, could you please let me know the solution.

Thanks & Regards,

Srikanth Pogula.

Avatar

Avatar
Level 1
gabork51827145
Level 1

Likes

0 likes

Total Posts

2 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
gabork51827145
Level 1

Likes

0 likes

Total Posts

2 posts

Correct reply

0 solutions
View profile
gabork51827145
Level 1

16-10-2017

I have the same problem. I got

guideContainer.af.submit.jsp Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Is this a server configuration or something else ?

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

01-05-2017

The AEM dispatcher should not be interfering with submitted data from a form to a servlet on publish.