Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Forcing the Use of the SSL Port / Why Dispatcher Works over HTTP

Avatar

Avatar
Validate 1
Level 2
25793466
Level 2

Likes

3 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
25793466
Level 2

Likes

3 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
25793466
Level 2

01-03-2017

I want to force the use of SSL in the admin interface of the publish instance.  Configuring this "https://docs.adobe.com/docs/en/aem/6-2/deploy/configuring/config-ssl.html#Forcing the Use of the SSL Port", does just that.  However, I need my dispatcher to connect over http (set through dispatcher.any).  This appears to work but now I'm wondering why publish does not force the redirect to SSL.

View Entire Topic

Avatar

Avatar
Validate 1
Level 2
25793466
Level 2

Likes

3 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
25793466
Level 2

Likes

3 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
25793466
Level 2

15-03-2017

You are correct.  It looks like the dispatcher makes the request to the publish instance using the end user facing URL host as the host header, which doesn't match the machinename.port I am forcing SSL on.