FavIcon Campaign Landing Page

abcd111

17-09-2020

Hi,

I'm having trouble changing the favicon for a Campaign Landing Page. 

 

I've tried:

 

<link rel="icon" type="image/png" href="./img/favicon.png">
 
<link rel="shortcut icon" type="image/x-icon" href="/libs/settings/wcm/designs/default/canvas/content/campaigns/.../_jcr_content/importer/img/favicon.ico">

and this seems to work in some Browsers (e.g. IE11, Firefox). Chrome instead uses the default favicon for the AEM instance. Is there an AEM setting/config to define the favicon for a Landing Page?
favicon landing page

Accepted Solutions (0)

Answers (2)

Answers (2)

BrianKasingli

MVP

17-09-2020

This can be also the path of your favicon, where /libs is a protected namespace. I suggest you to create a client library, ensure that allowProxy is set to true, then create an assets folder to place your favicon. Adobe recommends static images such as icons, favicons, patterns to be stored in the code, using client libraries, assets folder. 

Source: https://sourcedcode.com/blog/aem/how-to-serve-static-assets-in-aem-as-client-library-resources

Shashi_Mulugu

MVP

17-09-2020

@abcd111 yes I do faced this issue, Google chrome caches favicons and mostly reload time is not clear/known.

 

Please try entirely in new system or follow below blog post on how to clear chrome favicon cache.

https://www.webucator.com/how-to/how-force-refresh-of-faviconico.cfm

 

Also I see you configured favicon in metadata from libs path, will it not effect in publisher/dispatcher pages?

 

Please try to serve favicon from web server in httpd conf file as redirect to a fixed dam or /conf path or server location so that it will be consistent across the client systems.