External component (OOTB), downloading Static HTML in publisher. AEM6.3.0

Avatar

Avatar
Validate 10
Level 2
tushaar_srivastava
Level 2

Likes

8 likes

Total Posts

95 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 10
Level 2
tushaar_srivastava
Level 2

Likes

8 likes

Total Posts

95 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile
tushaar_srivastava
Level 2

19-05-2020

Hi All,

 

I have an open regarding OOTB External component from General group, i am using AEM6.3.0

 

The requirement is I have to include a HTML file to a page, it's like using iframe. Since i am using AEM6.3.0, limited to use OOTB External component instead Embed component.

Tushaar_Infy_0-1589876042818.png

 

In Author, I can see my HTML file is loading and can see the content of HTML inside External component. i.e. in page source we can see, and can see the content in Author.

 

<div class="external parbase section">
<iframe src="/content/dam/www/public/us/en/include/html-include-iframe/index.html" width="100%" height="700">
</iframe>

 

 

But when I publish this page and in Publisher I can see that particular file (index.html) is downloading to my Local system. (download on each and every refresh/reload of page)

image.png

 

How should I stop this downloading that is happening only in publisher, and can see the content of the HTML file that is included into iframe/External component

 

Thanks

 

@kautuk_sahni  @Arun_Patidar  @Vish_dhaliwal @ThatDeveloperGuy @dan_klco 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

573 likes

Total Posts

732 posts

Correct reply

241 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile

Avatar
Boost 500
MVP
Vijayalakshmi_S
MVP

Likes

573 likes

Total Posts

732 posts

Correct reply

241 solutions
Top badges earned
Boost 500
Give Back 50
Give Back 5
Ignite 10
Ignite 5
View profile
Vijayalakshmi_S
MVP

19-05-2020

Hi @tushaar_srivastava,

This downloading as attachment behavior is because of the header "Content-Disposition:attachment"

Per the screenshot you have shared, the html file (that you are trying to load inline in page) is available in DAM.

Look for the PID "com.day.cq.dam.core.impl.servlet.DamContentDispositionFilter" in OSGI components console and configure. (exclude text/html type - this header will not be added)

In 6.5.0, it is DAM Safe Binary Filter

ContentDisposition.png

Answers (1)

Answers (1)

Avatar

Avatar
Ignite 1
MVP
Ankur_Khare
MVP

Likes

159 likes

Total Posts

370 posts

Correct reply

58 solutions
Top badges earned
Ignite 1
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile

Avatar
Ignite 1
MVP
Ankur_Khare
MVP

Likes

159 likes

Total Posts

370 posts

Correct reply

58 solutions
Top badges earned
Ignite 1
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile
Ankur_Khare
MVP

19-05-2020

Can you try to add some external url  before trying dam one.

https://google.com