Highlighted

Extended forum suddenly stopped working

titli

17-08-2018

We have a forum component extended from the communities forum component which used to work fine before but now suddenly it has stopped working on only publish server. Working fine on the other.

When we see the logs this is what I see

16.08.2018 13:42:50.602 *ERROR* [10.145.116.66 [1534426970527] GET /content/iss/www-lexmark-com/tr_tr/test.html HTTP/1.1] com.adobe.cq.social.commons.impl.CollabAdapterFactory Unable to get service for "asipath" No provider configured in OSGi.

16.08.2018 13:42:50.602 *ERROR* [10.145.116.66 [1534426970527] GET /content/iss/www-lexmark-com/tr_tr/test.html HTTP/1.1] com.adobe.cq.social.commons.impl.CollabAdapterFactory Unable to get service for "asipath" No provider configured in OSGi.

16.08.2018 13:42:50.609 *ERROR* [10.145.116.66 [1534426970527] GET /content/iss/www-lexmark-com/tr_tr/test.html HTTP/1.1] com.day.cq.wcm.tags.IncludeTag Error while executing script body.jsp

org.apache.sling.api.scripting.ScriptEvaluationException:

at org.apache.sling.scripting.core.impl.DefaultSlingScript.call(DefaultSlingScript.java:388)

at org.apache.sling.scripting.core.impl.DefaultSlingScript.eval(DefaultSlingScript.java:171)

at org.apache.sling.scripting.core.impl.DefaultSlingScript.service(DefaultSlingScript.java:463)

at com.day.cq.wcm.tags.IncludeTag.includeScript(IncludeTag.java:176)

at com.day.cq.wcm.tags.IncludeTag.doEndTag(IncludeTag.java:93)

at org.apache.jsp.apps.lexmark.common.components.pages.base.base_jsp._jspx_meth_cq_005finclude_005f2(base_jsp.java:322)

at org.apache.jsp.apps.lexmark.common.components.pages.base.base_jsp._jspService(base_jsp.java:258)

at org.apache.sling.scripting.jsp.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)

at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:502)

at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:449)

at org.apache.sling.scripting.jsp.JspScriptEngineFactory.callJsp(JspScriptEngineFactory.java:284)

at org.apache.sling.scripting.jsp.JspScriptEngineFactory.access$100(JspScriptEngineFactory.java:102)

at org.apache.sling.scripting.jsp.JspScriptEngineFactory$JspScriptEngine.eval(JspScriptEngineFactory.java:536)

at org.apache.sling.scripting.core.impl.DefaultSlingScript.call(DefaultSlingScript.java:361)

We have not changed any code which could introduce any breakage. Any help on what could be causing this?

Replies