Error while doing code build deployment using pipeline in Cloud Manager

Avatar

Avatar

arunk85184451

Avatar

arunk85184451

arunk85184451

13-08-2020

Hi,

code build is getting failed while Build Image. can anyone please help to fix this issue 

 

arunk85184451_0-1597337665759.png

below the error 

 

+ wget -O /tmp/dispatcher/dispatcher-configuration.zip 'https://cm0pl0va80stor0prd.file.core.windows.net/cdbd4994-837a-4d0e-8af4-d6b433b2e3c9/build/aem-guid...'
--2020-08-13 16:20:37-- https://cm0pl0va80stor0prd.file.core.windows.net/cdbd4994-837a-4d0e-8af4-d6b433b2e3c9/build/aem-guid...
Resolving cm0pl0va80stor0prd.file.core.windows.net (cm0pl0va80stor0prd.file.core.windows.net)... 52.239.153.8
Connecting to cm0pl0va80stor0prd.file.core.windows.net (cm0pl0va80stor0prd.file.core.windows.net)|52.239.153.8|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 16149 (16K) [application/octet-stream]
Saving to: ‘/tmp/dispatcher/dispatcher-configuration.zip’

0K .......... ..... 100% 25.8M=0.001s

2020-08-13 16:20:37 (25.8 MB/s) - ‘/tmp/dispatcher/dispatcher-configuration.zip’ saved [16149/16149]

+ validate_configuration /tmp/dispatcher/dispatcher-configuration.zip
+ local zippedConfiguration=/tmp/dispatcher/dispatcher-configuration.zip
+ /usr/bin/dispatcher-configuration-validator full /tmp/dispatcher/dispatcher-configuration.zip
Cloud manager validator 2.0.21
2020/08/13 16:20:37 Apache configuration uses non-whitelisted directives:
conf.d/enabled_vhosts/wknd.vhost:1: ../available_vhosts/wknd.vhost
2020/08/13 16:20:37 Dispatcher configuration validation failed:
conf.dispatcher.d/enabled_farms/default.farm:1: extra characters following label "/default.farm" are ignored
The command '/bin/sh -c AZCOPY="/usr/bin/azcopy" VALIDATOR_BINARY="/usr/bin/dispatcher-configuration-validator" DISPATCHER_CONFIGURATION_LOCATION=$dispatcherConfigurationLocation DISPATCHER_CONFIGURATION_DESTINATION=$dispatcherConfigurationDestination RUN_MODE=$runmode ./validateDispatcherConfiguration.sh' returned a non-zero code: 2
2020/08/13 16:20:38 Container failed during run: build. No retries remaining.
failed to run step ID: build: exit status 2

Run ID: ca2fhf failed after 1m26s. Error: failed during run, err: exit status 1

 

View Entire Topic

Avatar

Avatar

Oleksii_Chuiev

Avatar

Oleksii_Chuiev

Oleksii_Chuiev

03-11-2020

@arunk85184451 we too faced with such an issue. For us it seems was related to broken symlinks.

/dispatcher/src/conf.d/enabled_vhosts/default.vhost is a symlink to /dispatcher/src/conf.d/available_vhosts/default.vhost
the same
/dispatcher/src/conf.dispatcher.d/enabled_farms/default.farm is a symlink to /dispatcher/src/conf.dispatcher.d/available_farms/default.farm

 

After working with the code in Windows we've found that symlinks became broken. Quick fix for us - copy content from origin available_vhosts/available_farms to enabled_vhosts/available_farms (so we have real content instead of reference to another files). Not sure if this is a good solution, but it helped. Btw, not clear how such a symlinks should work in Windows.