[ERROR] Filter root's ancestor '/apps' is not covered by any of the specified dependencies.

Avatar

Avatar

rajeev_yadav

Avatar

rajeev_yadav

rajeev_yadav

21-08-2018

I am trying to upgrade content  package plugin from 0.0.24 to 0.5.24. When trying to build code with upgraded version, I am getting below build errors:

[ERROR] Filter root's ancestor '/apps' is not covered by any of the specified dependencies.

My filter.xml looks like:

<?xml version="1.0" encoding="UTF-8"?>

<workspaceFilter version="1.0">

    <filter root="/apps/foo"  />

</workspaceFilter>

Anyone experienced this issue or knows on what could be the reason here?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Arun_Patidar

MVP

Total Posts

2.9K

Likes

1.0K

Correct Answer

831

Avatar

Arun_Patidar

MVP

Total Posts

2.9K

Likes

1.0K

Correct Answer

831
Arun_Patidar
MVP

21-08-2018

Hi,

Could you problem due updating existing archetype with new version, but not sure. Can you try 0.5.1 working for me. I tried both latest 0.5.24 and 1.0.2 versions with archetype 11 not working for me as well.

Answers (5)

Answers (5)

Avatar

Avatar

KaushikNitin

Avatar

KaushikNitin

KaushikNitin

20-10-2020

Add valid roots[1] or disable[2] it .
[1] <configuration>
<packageType>application</packageType>
<validatorsSettings>
<jackrabbit-filter>
<options>
<validRoots>/apps/myapp</validRoots>
</options>
</jackrabbit-filter>
</validatorsSettings>
</configuration>
[2]
<configuration>
<packageType>mixed</packageType>
<validatorsSettings>
<jackrabbit-packagetype>
<isDisabled>true</isDisabled>
</jackrabbit-packagetype>
</validatorsSettings>
</configuration>

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

21-08-2018

Report that bug to cust care by opening a ticket so it can get fixed. In mean time - use the version that builds and works in your AEM environment.

Avatar

Avatar

rajeev_yadav

Avatar

rajeev_yadav

rajeev_yadav

21-08-2018

Scott - I changed it to 0.5.1 .. but somewhere I read that 0.5.24 is stable release.. In future if we try to upgrade it then it would good if this bug is fixed.

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

21-08-2018

I recommend using the version that works.

Avatar

Avatar

rajeev_yadav

Avatar

rajeev_yadav

rajeev_yadav

21-08-2018

Thanks Arun. It is building fine with 0.5.1.

Could it be bug in 0.5.24?