Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Empty/Blank Page issues with Experience Fragment

Avatar

Avatar
Validate 10
Level 2
v1101
Level 2

Likes

4 likes

Total Posts

150 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Validate 10
Level 2
v1101
Level 2

Likes

4 likes

Total Posts

150 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile
v1101
Level 2

15-05-2021

Hello - I am facing some issues with experience fragment(XF). All of a sudden, the experience fragment master variant is empty/blank and I still see the content in the child variations. This is happening for multiple XFs. Not sure what is causing the issue. Could someone throw some light on this?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 100
Level 10
asutosh_jena
Level 10

Likes

559 likes

Total Posts

676 posts

Correct Reply

194 solutions
Top badges earned
Give Back 100
Boost 500
Affirm 100
Ignite 1
Establish
View profile

Avatar
Give Back 100
Level 10
asutosh_jena
Level 10

Likes

559 likes

Total Posts

676 posts

Correct Reply

194 solutions
Top badges earned
Give Back 100
Boost 500
Affirm 100
Ignite 1
Establish
View profile
asutosh_jena
Level 10

15-05-2021

Hi @v1101 

 

Can you please check the error log and see what error it is throwing when you are trying to access the master variant?

You can find the error log in aem installation folder crx-quickstart/logs/error.log

 

Also please check if any specific component is present on those pages which all are breaking or it any for all the component.

 

Was there any recent changes that was done to the code are deployed on the instance?

Answers (1)

Answers (1)

Avatar

Avatar
Boost 100
Level 5
Bhuwan_B
Level 5

Likes

100 likes

Total Posts

97 posts

Correct Reply

35 solutions
Top badges earned
Boost 100
Give Back 3
Affirm 25
Establish
Give Back
View profile

Avatar
Boost 100
Level 5
Bhuwan_B
Level 5

Likes

100 likes

Total Posts

97 posts

Correct Reply

35 solutions
Top badges earned
Boost 100
Give Back 3
Affirm 25
Establish
Give Back
View profile
Bhuwan_B
Level 5

15-05-2021

@v1101 Can you check if you are using OOTB template or your own. Also please check if template's sling:resourceType points to the correct page component. Ensure you have proper user permissions to perform this task.