Eclipse Development tools error

Avatar

Avatar

Juan_Camacho_I_

Avatar

Juan_Camacho_I_

Juan_Camacho_I_

15-03-2016

Hi, I started having problems yesterday with my eclipse installation, I am trying to set up Eclipse again with AEM development tools and I don't stop getting this error when creating a project (I have tried both Mars and Luna version that its supposed to be supported by AEM tools):

"The server does not support version 2.4 of the J2EE Web module specification."

I don't know if this is a known error whether it is caused by the new version of the tools.

I attach a pic of the warnings that Eclipse shows after trying to create a new Project

 

I don't know if you could help me with this

Thanks in advance for your help

Juan

View Entire Topic

Avatar

Avatar

ronnyfm

Avatar

ronnyfm

ronnyfm

29-03-2016

Thanks Feike, I didn't have the chance to post here, but I also found that workaround, but not only that, but the real cause is the archetype itself.

That is, as you stated the best is not to deploy to the server when creating the project, but creating the server after that.

The message about the Servlet 2.4 API specification is fixed by upgrading the definition in the pom.xml, the same applies to the Java JDK, event the most recent archetype (10) is using JDK 1.6, when in fact, the recommended JDK for AEM is 1.7 or greater, that also must to be updated.

After that, I create a new Server (updating the port numbers too) and add the modules, after all of this being done Eclipse effectively publish to the AEM instance.