Dual Header Issue in Experience Fragments

Avatar

Avatar

v1101

Avatar

v1101

v1101

18-06-2020

Hello Team - We are using AEM 6.5, After creating the experience fragment, I get a pop-up dialog for successful creation with "Done" & "Open" button, if I click the open button from there, I get a dual header like the below and not able to use the menu options. But the same opens perfectly when I open the experience fragment from the folder (Using Edit option). Could somebody throw some light to resolve the issue.

 

Header.PNG

@smacdonald2008 

@Arun_Patidar 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

khamat_bn

Avatar

khamat_bn

khamat_bn

20-06-2020

Hi @v1101 ,

 

Its the issue with your Experience Fragment Template. Check the page which experience fragment is using. You can remove context Hub lines from page if not required. There should be two files if you are not exploring much in XF .

1. customFooterLibs.html

2. customHeaderLibs.html

Also, Please check-in XF template structure that you have included any other component mistakenly in nodes or in properties.

You can also try to create XF in the existing project and compare the structure.

 

Happy Coding 🙂

~BK

 

Answers (2)

Answers (2)

Avatar

Avatar

Varun_Shakya

MVP

Avatar

Varun_Shakya

MVP

Varun_Shakya
MVP

18-06-2020

It seems there is an issue with your template.Try creating experience fragment with OOTB(We-Retail Template) once.  

Error log might be having information about the issue dig through that . 

 

Avatar

Avatar

Arun_Patidar

MVP

Total Posts

3.0K

Likes

1.1K

Correct Reply

840

Avatar

Arun_Patidar

MVP

Total Posts

3.0K

Likes

1.1K

Correct Reply

840
Arun_Patidar
MVP

20-06-2020

Check sling resource type in the Experience fragment template and template type(initial and structure)

e.g. https://github.com/Adobe-Marketing-Cloud/aem-sample-we-retail/tree/master/ui.content/src/main/conten...