Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Dual Header Issue in Experience Fragments

Avatar

Avatar
Validate 1
Level 2
v1101
Level 2

Likes

4 likes

Total Posts

136 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Validate 1
Level 2
v1101
Level 2

Likes

4 likes

Total Posts

136 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
v1101
Level 2

18-06-2020

Hello Team - We are using AEM 6.5, After creating the experience fragment, I get a pop-up dialog for successful creation with "Done" & "Open" button, if I click the open button from there, I get a dual header like the below and not able to use the menu options. But the same opens perfectly when I open the experience fragment from the folder (Using Edit option). Could somebody throw some light to resolve the issue.

 

Header.PNG

@smacdonald2008 

@Arun_Patidar 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Ignite 1
Level 3
khamat_bn
Level 3

Likes

31 likes

Total Posts

54 posts

Correct Reply

12 solutions
Top badges earned
Ignite 1
Give Back 3
Give Back
Boost 5
Boost 3
View profile

Avatar
Ignite 1
Level 3
khamat_bn
Level 3

Likes

31 likes

Total Posts

54 posts

Correct Reply

12 solutions
Top badges earned
Ignite 1
Give Back 3
Give Back
Boost 5
Boost 3
View profile
khamat_bn
Level 3

20-06-2020

Hi @v1101 ,

 

Its the issue with your Experience Fragment Template. Check the page which experience fragment is using. You can remove context Hub lines from page if not required. There should be two files if you are not exploring much in XF .

1. customFooterLibs.html

2. customHeaderLibs.html

Also, Please check-in XF template structure that you have included any other component mistakenly in nodes or in properties.

You can also try to create XF in the existing project and compare the structure.

 

Happy Coding 🙂

~BK

 

Answers (2)

Answers (2)

Avatar

Avatar
Ignite 1
MVP
Varun_Shakya
MVP

Likes

105 likes

Total Posts

82 posts

Correct Reply

20 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 50
View profile

Avatar
Ignite 1
MVP
Varun_Shakya
MVP

Likes

105 likes

Total Posts

82 posts

Correct Reply

20 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 50
View profile
Varun_Shakya
MVP

18-06-2020

It seems there is an issue with your template.Try creating experience fragment with OOTB(We-Retail Template) once.  

Error log might be having information about the issue dig through that . 

 

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,260 likes

Total Posts

3,140 posts

Correct Reply

886 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,260 likes

Total Posts

3,140 posts

Correct Reply

886 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

20-06-2020

Check sling resource type in the Experience fragment template and template type(initial and structure)

e.g. https://github.com/Adobe-Marketing-Cloud/aem-sample-we-retail/tree/master/ui.content/src/main/conten...