Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Doesn't apply all the translations

Avatar

Avatar
Level 1
NSzolnoki921
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
NSzolnoki921
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
View profile
NSzolnoki921
Level 1

09-04-2021

I have a tool which download xml files if I start the translation project, then it sync back into AEM, when the translation is done.

The issue is, only the title-s synched into AEM, and the weird thing, if I manually download the zip package with the export button, the files are translated files, so the right translation sent to AEM.

NSzolnoki921_0-1617955091895.png

On the left side you can see the file I downloaded with the export button, on the right side you can see the page in preview.

I am using AEM 6.5

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar
Give Back 50
MVP
Vijayalakshmi_S
MVP

Likes

436 likes

Total Posts

574 posts

Correct Reply

191 solutions
Top badges earned
Give Back 50
Give Back 5
Ignite 10
Ignite 5
Ignite 3
View profile

Avatar
Give Back 50
MVP
Vijayalakshmi_S
MVP

Likes

436 likes

Total Posts

574 posts

Correct Reply

191 solutions
Top badges earned
Give Back 50
Give Back 5
Ignite 10
Ignite 5
Ignite 3
View profile
Vijayalakshmi_S
MVP

12-04-2021

Hi @NSzolnoki921,

Could you please share below details

  • High level details about your tool/custom translation connector
  • Status on Translation project/job for these content pages
  • Is it working before or first time implementation

 

NSzolnoki921

Hi @Vijayalakshmi_S,

 

Absolutely, here they are:

- High level details -

- You create a configuration for the translation integration

- You create a translation project and select the custom provider and configuration for it

- Add page/pages from Master languages

- Use create a language copy

- Click on start translation

- File/files sent to the CAT tool

- State of the file is "Committed for translation"

- When the translation finished, files took from CAT tool by the plugin, save as an UTF-8 file and change the state to "Translated"

- As AEM imports the file which state is "Translated", it imports the file into AEM

- Now the state of the page is "Ready for review", but when I open with Preview in sites, it still shows me the original language page

I am not sure that this error message shows, that why the translation not applied:

13.04.2021 06:52:57.328 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl StarResource given at /content/we-retail/language-masters/hu/experience/skitouring/jcr:content/root/responsivegrid/contentfragment/par0/*: no parent: no LiveCopy
13.04.2021 06:52:57.338 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] org.apache.sling.engine.impl.request.RequestData SlingRequestProgressTracker not found in request attributes
13.04.2021 06:52:57.844 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl StarResource given at /content/we-retail/language-masters/hu/experience/skitouring/jcr:content/root/responsivegrid/contentfragment/par1/*: no parent: no LiveCopy
13.04.2021 06:52:57.861 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl StarResource given at /content/we-retail/language-masters/hu/experience/skitouring/jcr:content/root/responsivegrid/contentfragment/par2/*: no parent: no LiveCopy
13.04.2021 06:52:57.877 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl StarResource given at /content/we-retail/language-masters/hu/experience/skitouring/jcr:content/root/responsivegrid/contentfragment/par3/*: no parent: no LiveCopy
13.04.2021 06:52:57.892 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl StarResource given at /content/we-retail/language-masters/hu/experience/skitouring/jcr:content/root/responsivegrid/contentfragment/par4/*: no parent: no LiveCopy
13.04.2021 06:52:57.910 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl StarResource given at /content/we-retail/language-masters/hu/experience/skitouring/jcr:content/root/responsivegrid/contentfragment/par5/*: no parent: no LiveCopy
13.04.2021 06:52:57.927 *WARN* [0:0:0:0:0:0:0:1 [1618289574635] GET /content/we-retail/language-masters/hu/experience/skitouring.html HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl StarResource given at /content/we-retail/language-masters/hu/experience/skitouring/jcr:content/root/responsivegrid/contentfragment/par6/*: no parent: no LiveCopy

 

I am using the builtin We.Retail page for testing.

 

 

Vijayalakshmi_S

Hi @NSzolnoki921,

Can you cross check if translation_rules.xml has entry for content fragment component and property named text within it. (or text  property in general should have been allowed)

Per the screenshot posted in query, looks like content as part of Content Fragment component alone is not translated.