Display Mode is not visible while using Content fragment in AEM 64 page

Avatar

Avatar
Validate 1
Level 2
Dineshkumar_L
Level 2

Likes

9 likes

Total Posts

36 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
Dineshkumar_L
Level 2

Likes

9 likes

Total Posts

36 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
Dineshkumar_L
Level 2

25-06-2018

Hi All,

I am trying to use content fragment feature in AEM64 for one of my client requirement. Following are the steps which I performed by following Adobe help docs:

  1. Created a Content Fragment Model by navigating to http://localhost:4502/libs/dam/cfm/models/console/content/models.html/conf
  2. Added multiple data type elements to the model for e.g: Single Line Text, Multi Line Text and Date & Time.
  3. Created a content fragment using the above created model and filled the content
  4. I have created a page and added the OOTB Content Fragment Component which is under General component group.
  5. I configured the Content Fragment Component by choosing my Content Fragment path (Which I saved in above step#3).
  6. While configuring the content fragment, I could not see the "Display Mode" option. Whereas Adobe documents and videos says, this "Display Mode" option will help author to set either "Single Element" or "Multiple Elements". By Default I am getting an option to choose only single Element. please find the attached snap shot.
  7. I did not set the display mode property to single element anywhere explicitly. Am I missing anything?

CF_DisplayMode_Missing.png

Thank you!

Dinesh kumar L.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,444 likes

Total Posts

3,326 posts

Correct reply

941 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,444 likes

Total Posts

3,326 posts

Correct reply

941 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

26-06-2018

Hi,

If you are referring Page Authoring with Content Fragments

that clearly says if you'll use we.retail content fragment then only you can see that option. That is custom Component not OOTB.

Screen Shot 2018-06-26 at 4.33.29 PM.png

Thanks

Arun

Answers (4)

Answers (4)

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,444 likes

Total Posts

3,326 posts

Correct reply

941 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,444 likes

Total Posts

3,326 posts

Correct reply

941 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

21-11-2018

Hi,

You need to use wcm core contentfragment components.

/apps/core/wcm/extension/components/contentfragment/v1/contentfragment

Weretail example is also using same in above.

Avatar

Avatar
Level 1
Tim_White
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
Tim_White
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
Tim_White
Level 1

21-11-2018

I'm looking at Page Authoring with Content Fragments ​ and I do not see where it says that the Content fragment they are using has been customized. And there version of We.Retail that I have does NOT have the Display Mode option. All the documentation I have seen says that if the Element Field is empty it will pull in all elements; yet there is no way to have Element field be empty.

How do we get this functionality? The content fragments are very useful for my use case if I can only pull in one of the elements.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

27-06-2018

Excellent community interaction - thanks!

Avatar

Avatar
Validate 1
Level 2
Dineshkumar_L
Level 2

Likes

9 likes

Total Posts

36 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
Dineshkumar_L
Level 2

Likes

9 likes

Total Posts

36 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
Dineshkumar_L
Level 2

26-06-2018

Thanks Arun.

Then the OOTB Content Fragment component under general can be used to render content from only one element, even though the model has more than one element to capture content.

Regards,

Dinesh.