Dispatcher Flushing Issue

Avatar

Avatar
Give Back
Level 2
Parusharam
Level 2

Likes

4 likes

Total Posts

20 posts

Correct reply

2 solutions
Top badges earned
Give Back
Validate 1
Establish
Boost 3
Boost 1
View profile

Avatar
Give Back
Level 2
Parusharam
Level 2

Likes

4 likes

Total Posts

20 posts

Correct reply

2 solutions
Top badges earned
Give Back
Validate 1
Establish
Boost 3
Boost 1
View profile
Parusharam
Level 2

25-02-2020

Problem:

When I tried to invalidate dispatcher cache using acs aem commons dispatcher flush,"/content/" is getting removed from the path and appending the remaining path to the doc root and trying to flush the new path which is not a valid path.

 

Example:
When I flush "/content/abc/home.html"  "/content"is getting trimmed and remaining URL is getting appended to the "/opt/aem/data" and the final url will be /opt/aem/data/abc/home.html which is invalid path in apache and the cache invalidation is failed.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

26-02-2020

Ideally, Flush should be automatically triggered when you replicate a page from author to publish.

 

That said, You might want to check for any URL rewriting Or linkchecker configuration causing the issue.

Answers (0)