Dispatcher: Apache unable to start.

Avatar

Avatar

ronnyfm

Avatar

ronnyfm

ronnyfm

31-05-2018

Hello, I am facing a weird issue installing a dispatcher for an author instance.

The configuration for the author is based in a previous installation that I know it works fine.

Now back to this project, the dispatchers for the publish instances are working fine. They do have the same httpd version, same RHEL version, same dispatcher module (I even copied the same .so from the working dispatchers).

But Apache is unable to start and I do not have many useful info, since Apache doesn't write to the error_log, also dispatcher.log is not even created.

apachectl configtest

output says the syntax is OK.

In fact, if I remove all the dispatcher configuration, and only try to load the module, Apache fails. So, I suspect is something with the .so itself, but as I said, it is the same exact file in the working dispatchers.

Any hints or actions in order to get a more verbose output? Thanks.

View Entire Topic

Avatar

Avatar

ronnyfm

Avatar

ronnyfm

ronnyfm

04-06-2018

Yeah, I sometimes forget to document all differences when selinux appears to be an issue, but I was with the latest dispatcher version, latest Apache 2.4.6 and latest RHEL. After solving this issue, I also had to fix permissions for the docroot, though I applied the commands found in the Installation guide. I solved by following the solution found here: centos7 - CentOs 7 & SELInux: User cant write in the Webroot of Apache - Server Fault