Design time path not found for model with ID: /var/workflow/models/request_for_deactivation

Avatar

Avatar

saibul

Avatar

saibul

saibul

09-11-2020

We are getting below error log when accessing workflow models from touch UI console and the model UI is blank.

This is OOTB workflow, not sure how to resolve this issue.

 

10.11.2020 06:48:34.518 *WARN* [204.153.122.4 [1604990914422] GET /libs/cq/workflow/admin/console/content/models.html HTTP/1.1] libs.cq.workflow.admin.console.components.item.workflowmodel.card.card$jsp Design time path not found for model with ID: /var/workflow/models/request_for_deactivation
10.11.2020 06:48:34.521 *ERROR* [204.153.122.4 [1604990914422] GET /libs/cq/workflow/admin/console/content/models.html HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException
java.lang.NullPointerException: null
at org.apache.jsp.libs.cq.workflow.admin.console.components.item.workflowmodel.card.card_jsp._jspService(card_jsp.java:498)
at org.apache.sling.scripting.jsp.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Anudeep_Garnepudi

Avatar

Anudeep_Garnepudi

Anudeep_Garnepudi

10-11-2020

Hi @saibul 

Check the below path exists in your repository. If you don't have that specific page you will get that error.

/libs/settings/workflow/models/request_for_deactivation.

As above page is missing you are gettingNullPointerException.

Hope this helps!

AG

Answers (1)

Answers (1)

Avatar

Avatar

Sandeep6

Avatar

Sandeep6

Sandeep6

10-11-2020

Hi @saibul ,

 

Have you upgraded your aem instance recently. If yes, please follow below article.

 

https://helpx.adobe.com/in/experience-manager/kb/cannot-read-workflow-model-error.html 

 

Thanks,

Sandeep.