Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Custom namespace not displaying in metadata schema editor form

Avatar

Avatar
Ignite 3
Level 1
jitendra_m
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile

Avatar
Ignite 3
Level 1
jitendra_m
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile
jitendra_m
Level 1

12-03-2019

Hi,

I have created a custom namespace in crx/explorer, but when mapping it to any field in metadata schema editor form, it is not displaying.

Please let me know if I am missing anything.

AEM version: 6.4

Thanks,

Jitendra

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

12-03-2019

Please describe the procedure you are doing to perform this use case. I am also checking with the team on this use case.

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

470 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

470 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

12-03-2019

How did you create the custom namespace ? Did you do it in http://localhost:4502/crx/explorer/nodetypes/index.jsp   ?

Avatar

Avatar
Ignite 3
Level 1
jitendra_m
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile

Avatar
Ignite 3
Level 1
jitendra_m
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile
jitendra_m
Level 1

13-03-2019

Hi Veena,

I have created custom namespace by opening http://localhost:4502/crx/explorer/index.jsp > Node Type Administration > Namspaces > created new namespace named "demo".

But when I am editing the metadata schema form and mapping this property to custom field, the namespace is not visible in the list.

Also, when I manually provide property in "Map to property" field, the custom field is working fine and it is actually showing the field when opening any asset's properties.

1710626_pastedImage_0.png

So, the only issue is namespace is not visible in mapping list in metadata schema form.

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

470 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

470 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

13-03-2019

I am not sure about the expected behavior.  Since it is saving , it should be fine I believe. I will do some RnD on existing behavior though