Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

custom experience fragment template does not show up during XF creation in 6.5.6

Avatar

Avatar
Validate 25
Level 4
jayv25585659
Level 4

Likes

46 likes

Total Posts

124 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Contributor 2
Ignite 5
View profile

Avatar
Validate 25
Level 4
jayv25585659
Level 4

Likes

46 likes

Total Posts

124 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Contributor 2
Ignite 5
View profile
jayv25585659
Level 4

28-03-2021

The problems happens on 2 AMS-hosted environments (sandbox and UAT). I haven't tried in our 6.5.6 prod environment yet as it was just given to us last week and I'm in the process of setting it up.

 

some notes/info:

  1. Only the built-in one shows up (in my case it's called Experience Fragment - screens variation). I know AMS has hidden some of the other built-in ones (example: Facebook, Pinterest and etc) but I do not know where they are hidden. But I do know the nodes exists (example: this /libs/cq/experience-fragments/components/xffacebook shows up CRXDE)

  2. I've looked at the logs and nothing shows up. The logs only show that I've accessed the create page.

  3. This experience fragment shows up fine in my local AEM running 6.5.6.

  4. This experience fragment shows up in our AMS-hosted UAT/prod environments running 6.4.x.

  5. This is the definition of the node

    <?xml version="1.0" encoding="UTF-8"?>
        <jcr:root xmlns:sling="http://sling.apache.org/jcr/sling/1.0" xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0"
           jcr:description="Page with specific components for Experience Fragments web variations"
           jcr:primaryType="cq:Component"
           jcr:title="Experience Fragment Web Variation Page"
           sling:resourceSuperType="cq/experience-fragments/components/xfpage/>
  6. I changed sling:resourceSuperType to sling:resourceType and still does not show up.

Any ideas on how to fix/where to look?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 100
Level 10
asutosh_jena
Level 10

Likes

559 likes

Total Posts

676 posts

Correct Reply

194 solutions
Top badges earned
Give Back 100
Boost 500
Affirm 100
Ignite 1
Establish
View profile

Avatar
Give Back 100
Level 10
asutosh_jena
Level 10

Likes

559 likes

Total Posts

676 posts

Correct Reply

194 solutions
Top badges earned
Give Back 100
Boost 500
Affirm 100
Ignite 1
Establish
View profile
asutosh_jena
Level 10

29-03-2021

Hi @jayv25585659 

You will need to add your template in the allowed template property. Please follow the below steps:

  1. Please navigate to the required Experience Fragments folder.
  2. Select the folder, and then Properties.
  3. Specify the regular expression for retrieving the required templates in the Allowed Templates field.
    e.g. /conf/(.*)/settings/wcm/templates/experience-fragment(.*)? OR the experience fragment template path. (screenshot below)

asutosh_j3_0-1617002591462.png

 

Please refer the adobe link for more details:
https://experienceleague.adobe.com/docs/experience-manager-64/authoring/authoring/experience-fragmen...

 

Hope this helps!

Thanks!

Answers (1)

Answers (1)

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

29-03-2021

Please follow @asutosh_jena steps. It should solve your issue. 

 

Thanks

Veena