Creating Custom Social Component (Comments) - Error extending comments component

Avatar

Avatar

snbaem

Avatar

snbaem

snbaem

11-01-2017

Hello All,

I tried to create a custom social component using this link at Creating an Adobe Experience Manager social component which is tested for AEM 6.0. However I am trying on AEM 6.2 (cq-socialcommunities-pkg-1.10.111.zip

I am able to run build successfully. But in my code I see this error on my CustomComment class "The type com.adobe.cq.social.commons.comments.internal.states.State cannot be resolved. It is indirectly referenced from required .class files". After the successful build, On my page with comment component I see the same error

If anyone tried this and faced same issue please let me know..

It did work for a colleague using AEM 6.2 (1.10.60) (some time back) but now they get same error with AEM 6.2 (1.10.111). Can that be something??

 

Update: Confirming - Doesnot work on AEM 6.2 FP2 (1.10.111), but works on AEM 6.2 FP1(1.10.60). I did go to my eclipse and set my dependencies to the FP1 (1.10.60) and I could see the error gone and expected changes as per customization.

Is there anything I am missing while working with AEM 6.2 FP2?

Appreciate any help..Thanks

View Entire Topic

Avatar

Avatar

Gdubz-57m2mu

Avatar

Gdubz-57m2mu

Gdubz-57m2mu

13-02-2017

Arun,

We're using the Unobfuscated 6.2 Uber-jar.

<dependency> <groupId>com.adobe.aem</groupId> <artifactId>uber-jar</artifactId> <version>6.2.0</version> <classifier>apis</classifier> <scope>provided</scope> </dependency>