$CQ is not defined in <div class="target parbase"> after update AEM 6.3-6.5

Avatar

Avatar
Validate 10
Level 3
arturl43391132
Level 3

Likes

18 likes

Total Posts

68 posts

Correct reply

10 solutions
Top badges earned
Validate 10
Validate 1
Ignite 1
Give Back
Boost 5
View profile

Avatar
Validate 10
Level 3
arturl43391132
Level 3

Likes

18 likes

Total Posts

68 posts

Correct reply

10 solutions
Top badges earned
Validate 10
Validate 1
Ignite 1
Give Back
Boost 5
View profile
arturl43391132
Level 3

23-04-2020

Hello, Adobe Community

 

We're in the process of migration AEM from 6.3 to 6.5. We've made first steps and now we have the problem with loading pages which have target areas:

arturl43391132_0-1587645443572.png

And the error is: Uncaught ReferenceError: $CQ is not defined.

 

Could you please suggest what's the problem can be?

 

Thanks.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back
Employee
shreyag72517995
Employee

Likes

7 likes

Total Posts

9 posts

Correct reply

5 solutions
Top badges earned
Give Back
Boost 5
Boost 3
Boost 1
Affirm 5
View profile

Avatar
Give Back
Employee
shreyag72517995
Employee

Likes

7 likes

Total Posts

9 posts

Correct reply

5 solutions
Top badges earned
Give Back
Boost 5
Boost 3
Boost 1
Affirm 5
View profile
shreyag72517995
Employee

24-04-2020

This issue was reported to the AEM engineering team. 

The solution provided was to add cq.shared dependency on "/etc/clientlibs/foundation/main".

 

Check if this helps. Also I would suggest you to  recompile all JSPs, invalidate Cache and rebuild the clientlibs.

Answers (0)