Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

CQ is not defined error pop up message in IE11

minisanu
Level 3
Level 3

HI Everyone,

We are getting CQ is not defined error message as popup in IE11.We are getting the same error in Chrome in console.

I have already gone through the forums for the solution but couldnt resolve it.

Please let me know how to get rid of this error.

1474947_pastedImage_0.png

Thanks

Mini

3 Replies
Rima_Mittal
Level 4
Level 4

Which AEM version are you using?

Do you see the error while trying editing in Classic UI or Touch UI?

minisanu
Level 3
Level 3

Hi Rima,

Im using AEM 6.2. We are facing this issue in classic ui.

Any leads on this issue?

Thanks

Rima_Mittal
Level 4
Level 4

If you will include init.jsp(which brings on the sidekick), the error would go away.

Have this in your headlibs.html :

<sly data-sly-include="/libs/wcm/core/components/init/init.jsp" data-sly-unwrap/>

Hope this helps!

minisanu
Level 3
Level 3

HI Rima,

I have already included in head .jsp  but still getting same error.

Thanks

smacdonald2008
Level 10
Level 10

Try a fresh install of AEM and let us know if you see this error still. That will tell us if there is a bug or some action performed in your AEM instance that caused this.

minisanu
Level 3
Level 3

hi smacdonald2008,

THis issue we are facing in all our environments like DEV,QA, STG and PROD. How could we install a fresh instance and check our code.We tried the same in local instance but whenever we deploy our code we are getting this issue.

Hemant_arora
Level 8
Level 8

You may need to include cq.jquery clientlib or tweak the clientLibs.

Can you share the URL of the page where I can reproduce ?

I just checked http://localhost:4502/cf#/content/geometrixx-gov/en/thankyou.html

i dont see any error.

Go to IE console and type CQ or $CQ, these should auto populate if they are available on the page.

Also try changing the order of the dependencies included in clientlib.