contents in RTE table displays in vertical

kevinx18367959

15-02-2019

Good morning Sir,

Another issue about RTE component which inherit core/wcm/components/text/v2/text. and I added cq:dialog configuration for it.

When editing content in RTE, I added a table in it, and contents display in table cells horizontal. After I save the dialog, and open the dialog again, contents in table display in vertical ! please see below snapshot.

content in table.png

This issue only occurs in Chrome, it works fine in Edge.

I'm using AEM 6.4

Thanks for your help!

Accepted Solutions (1)

Accepted Solutions (1)

smacdonald2008

15-02-2019

If you create a new Maven 15 project and test the default TEXT component on a fresh instance and clear CHROME Cache - are you still seeing this? 

Answers (3)

Answers (3)

Gaurav-Behl

MVP

15-02-2019

Most likely, there is a css conflict between your code/parent container and OOB v2/text. Could you debug or engage a frontend developer to debug? It should be something related to 'width' or 'max-width' property.

Steps:

open the developer toolbar in chrome via F12 key and inspect that table element's DOM and check the Style tab to find more clues.

kevinx18367959

15-02-2019

Hi smacdonald2008,

This issue disappeared after I removed the table content from page and created a new one.

For testing, I used the default TEXT component directly in my page,  and added Table feature, it works fine.

Then I compare the new configuration with the old one. no special is found.

Thanks!