Configuring dispatcher with IIS in windows 10

Avatar

Avatar

avinashg8602946

Avatar

avinashg8602946

avinashg8602946

27-06-2019

Hi,

I'm facing this error "HTTP Error 404.0 - Not Found The resource you are looking for has been removed, had its name changed, or is temporarily unavailable." when I setup dispatcher to the IIS. I tried all the steps mentioned in Adobe documentation Installing Dispatcher

This is the detailed error Information.

Detailed Error Information:

                

Module   IIS Web Core
Notification   MapRequestHandler
Handler   Dispatcher
Error Code   0x80070002

                

Requested URL   http://localhost:80/
Physical Path   C:\inetpub\wwwroot
Logon Method   Anonymous
Logon User   Anonymous

Can anyone help to resolve this issue.

My specification

Dispatcher: dispatcher-iis-windows-x64-4.2.3

Os: Windows 10

IIS: Latest version (10)

Thanks & Regards,

Avinash

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

aemmarc

Employee

Avatar

aemmarc

Employee

aemmarc
Employee

28-06-2019

That version of the Dispatcher module is old, you really should be on 4.3.2 not 4.2.3

See IIS section to pull the latest build:

AEM Dispatcher Release Notes

Answers (5)

Answers (5)

Avatar

Avatar

maryiah56475990

Avatar

maryiah56475990

maryiah56475990

26-11-2019

I have faced the same issue on IIS 10 + 4.3.3 dispatcher, and solved it by doing the following:

  • Open "Handler Mappings"
  • Open an edit dialog of disp_iis.dll mapping
  • Open "Request Restrictions" in the bottom of a dialog
  • Uncheck "Invoke handler only if request is mapped to:" checkbox

By default, IIS Manager configures all handlers to be invoked for files. However, when we first integrate the Dispatcher module, there are no cached files under docroot yet which leads to 404 error.

Avatar

Avatar

AdobeID24

Avatar

AdobeID24

AdobeID24

07-10-2019

dispatcher on iis server

I am getting the same issue and I performed all the action as discussed above ...what small or big thing I am missing here please let me know . even dispatcher.log file is not getting generated in my case

Avatar

Avatar

antond26624417

Avatar

antond26624417

antond26624417

17-07-2019

Moving cache to the D disk simplified work with cache permissions for me. Now everything is fine.

Avatar

Avatar

antond26624417

Avatar

antond26624417

antond26624417

17-07-2019

Issue related to "Not Found" error has been resolved.
Solution for me was also applying steps 6,7,8,9 from "Integrating the Dispatcher ISAPI Module - IIS 8.5 and 10" section for IIS 10 (Installing Dispatcher​).

Now I'm facing another issue with cache permissions.

I always see the following message:
"Unable to create parent directory C:\inetpub\wwwroot\content\mysite\en: Permission denied".

Avatar

Avatar

antond26624417

Avatar

antond26624417

antond26624417

17-07-2019

I'm facing the same issue using the latest Dispatcher module.