Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Components are not coming in side rail in touch UI

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

17-10-2017

Hi All,

Need help to show the components list in side rail of touch UI AEM 6.2.

> I have selected the components in design mode parsys. This is working good in classic UI sidekick. I can see all the components there but not in touch UI.

> I also added editconfig node in component but still of no use

Thanks in advance for your help.

Regards,

SD

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

112 likes

Total Posts

394 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

112 likes

Total Posts

394 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile
Prince_Shivhare
Level 7

17-10-2017

Hi,

There are some possible reasons:

- When your component label and title name is same. it should not be same.

- There should be blank classic ui dialog or edit config node to should in touch ui.

- if you have not included the component using parsys in design mode. make sure which parsys you are using it is JSP (foundation/component/parsys) or sightly (wcm/foundation/component/parsys).

Please check and let us know!!!

Regards,
Prince

Answers (7)

Answers (7)

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

24-10-2017

I tried on new instance and it worked. I found that due to some other projects on my instance I faced this issue. Thanks all for your help.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

24-10-2017

We have given you the steps. Try what Kautuk has suggested, Try on a Fresh AEM instance.

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,164 likes

Total Posts

6,273 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,164 likes

Total Posts

6,273 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

24-10-2017

Can you please check this on the fresh instance?

And if this is still reproducible then please share with us the steps to reproduce it.

~kautuk

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

24-10-2017

Hey All,

Is there any solution for this? Please provide some suggestions.

Thanks,

SD

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

17-10-2017

Hi All,

Its still the same even though I have done all the things, please find below my answers,

- When your component label and title name is same. it should not be same. - My component label and titles are different

- There should be blank classic ui dialog or edit config node to should in touch ui. - I have not added any thing under classic ui dialog and edit config

- if you have not included the component using parsys in design mode. make sure which parsys you are using it is JSP (foundation/component/parsys) or sightly (wcm/foundation/component/parsys). - I have added components in design mode and used sightly parsys (wcm/foundation/components/parsys)

- Even I am getting below design dialog :

1326808_pastedImage_0.png

Appreciate your help

Regards,

SD

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

471 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

17-10-2017

scott is correct . . i do believe you might have missed the touch dialog.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

17-10-2017

To see all components in the TOuch UI - you need to click the Design mode in AEM. See here:

AAAA22.png

Also - make sure that the component has a Touch UI dialog.