component not displayed

Avatar

Avatar
Validate 1
Level 2
sreedobe
Level 2

Likes

4 likes

Total Posts

67 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Validate 1
Level 2
sreedobe
Level 2

Likes

4 likes

Total Posts

67 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 5
Give Back 3
View profile
sreedobe
Level 2

30-10-2020

dev-author-globalnav-1.pngdev-author-globalnav-1-1.pngdev-publish-globalnav-footer-missing.pngdev-publish-globalnav-footer-missing-1-1.pngHi,

 

I have a header, footer components below /apps/<my-site>/components/structure

In my local author, publish both header, footer displayed and I can see html generated in page source.

 

When I pushed code to upper environments

 

in DEV env: author displays header, footer, publish does not display (I do not see html for header, footer components generated)

 

in Stage env: author, publish both does not display header, footer

 

Yes code is deployed properly  for header, footer, templates in all environments.

 

I do not have access to osgi console , logs in upper environments, any ideas why this happening only for header, footer ... other components on page rendered fine.

 

Thanks.

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 3
MVP
Manjunath_K
MVP

Likes

140 likes

Total Posts

188 posts

Correct reply

61 solutions
Top badges earned
Give Back 3
Give Back
Boost 50
Boost 5
Boost 3
View profile

Avatar
Give Back 3
MVP
Manjunath_K
MVP

Likes

140 likes

Total Posts

188 posts

Correct reply

61 solutions
Top badges earned
Give Back 3
Give Back
Boost 50
Boost 5
Boost 3
View profile
Manjunath_K
MVP

30-10-2020

Hi @sreedobe,

Can you please add screenshot of header component html & html structure from browser page source where header is missing. also if you access to crxde in higher environment try reloading the page & check if there are any error printed on crxde console tab where logs will be generated

 

crxde.PNG

Answers (4)

Answers (4)

Avatar

Avatar
Establish
MVP
BrianKasingli
MVP

Likes

646 likes

Total Posts

607 posts

Correct reply

239 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Establish
MVP
BrianKasingli
MVP

Likes

646 likes

Total Posts

607 posts

Correct reply

239 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
BrianKasingli
MVP

06-11-2020

@sreedobe it might because your user from the upper environment does not have permissions. Anything from the ./crx-quickstart/logs/error.log log file, please share these screenshots with us.

Avatar

Avatar
Validate 1
MVP
Umesh_Thakur
MVP

Likes

147 likes

Total Posts

164 posts

Correct reply

53 solutions
Top badges earned
Validate 1
Applaud 25
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
MVP
Umesh_Thakur
MVP

Likes

147 likes

Total Posts

164 posts

Correct reply

53 solutions
Top badges earned
Validate 1
Applaud 25
Ignite 3
Ignite 1
Give Back 5
View profile
Umesh_Thakur
MVP

05-11-2020

It seems like you are using SPA, and the clientlibs, responsible to generate header and footer, is not available on the instance, where you are facing issue.

So it will be better to first try to troubleshoot the issue with the IP:port URL, if it works fine with that then do the required changes to make the clientlibs available on the dispatcher URL.

Hope this will help.

Umesh Thakur

Avatar

Avatar
Ignite 1
MVP
SureshDhulipudi
MVP

Likes

163 likes

Total Posts

174 posts

Correct reply

49 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back 10
Give Back
View profile

Avatar
Ignite 1
MVP
SureshDhulipudi
MVP

Likes

163 likes

Total Posts

174 posts

Correct reply

49 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back 10
Give Back
View profile
SureshDhulipudi
MVP

05-11-2020

Did you try compare with other working Custom components (on both author and publish instances in higher environments )

you can request for logs from admin (who has access to the logs in higher environment)

Avatar

Avatar
Validate 1
Level 3
sdouglasmc
Level 3

Likes

22 likes

Total Posts

83 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 3
sdouglasmc
Level 3

Likes

22 likes

Total Posts

83 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
sdouglasmc
Level 3

01-11-2020

These are custom components correct?  Are all the pages you have configured in the Publish instance?

I've seen cases where people create their own headers/footers and don't bother checking existence of the pages (bypassing linkchecker).