com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

02-11-2017

Hi all, when we open a page we can see in our log file these WARN:

02.11.2017 16:18:12.377 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.day.cq.wcm.webservicesupport.impl.ConfigurationManagerImpl Cloud service [] not found

02.11.2017 16:18:12.398 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/jquery

02.11.2017 16:18:12.398 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/utils

02.11.2017 16:18:12.399 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/jquery/granite

do you know how can I remove this warning?

AEM 6.3.0

Thanks in advance

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

05-11-2017

Please create a support ticket for this and also share the solution with the community.

~kautuk

Answers (17)

Answers (17)

Avatar

Avatar
Validate 1
Level 10
edubey
Level 10

Likes

277 likes

Total Posts

1,502 posts

Correct reply

392 solutions
Top badges earned
Validate 1
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Validate 1
Level 10
edubey
Level 10

Likes

277 likes

Total Posts

1,502 posts

Correct reply

392 solutions
Top badges earned
Validate 1
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile
edubey
Level 10

13-11-2017

I am not quite sure but looks it has to do with something with clientlib proxy. Check the allowProxy once

https://helpx.adobe.com/experience-manager/6-3/sites/developing/using/clientlibs.html#main-pars_titl...

Thanks

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

14-11-2017

Sure,

I changed in the original clientlib path the property allowProxy to 'false'. For exmaple for the next WARN

02.11.2017 16:18:12.398 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/utils

I know that library is in /libs/clientlibs/granite/utils, so using the crx/de, go to that location and change the value.

This path /apps/clientlibs/granite/utils is requested by the new ClientLib Servlet because /libs/clientlibs/granite/utils has allowProxy = true

iamge.png

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

14-11-2017

Hi edubey, i think you're right, if I change the allowProxy property for those paths (/apps/clientlibs/granite/jquery,

/apps/clientlibs/granite/utils, /apps/clientlibs/granite/jquery/granite) the warnings disappear

smacdonald2008 kautuksahni

I think we found something, this seems to come configured ootb, could you help us?

Thanks in advance

Avatar

Avatar
Give Back 3
Level 2
ananta99
Level 2

Likes

2 likes

Total Posts

18 posts

Correct reply

1 solution
Top badges earned
Give Back 3
Validate 1
Give Back
Boost 1
Applaud 5
View profile

Avatar
Give Back 3
Level 2
ananta99
Level 2

Likes

2 likes

Total Posts

18 posts

Correct reply

1 solution
Top badges earned
Give Back 3
Validate 1
Give Back
Boost 1
Applaud 5
View profile
ananta99
Level 2

13-11-2017

victor.toledo.3sharesmacdonald2008

Is there a resolution for this issue?

We are facing the same problem once the system is upgraded from 6.1 to 6.3. Please advise.

Thanks,

Ananta

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

03-11-2017

Hey, thanks for your response. But those errors are from AEM, we have 3 instances of author/publish with 3 different sites and we have the same errors. We are migrating from 6.1 to 6.3, on 6.1 we dont have any errors/warn.

Seems to be some aem compononent/object is requesting for those paths.

I created an empty page without any component and it's the same, i have those warnings.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

02-11-2017

Looks like some one placed content under /apps named clientlibs. Not really the best place to put a clientlibs. Most are placed under /etc - for example.

AClientLib.png

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

15-11-2017

Hi nandand81957514 , yes, will be overwritten.  I just did it to test if that is the problem. By changing that property in those folders within libs, the warning stopped appearing. So, my conclusion was that this was the problem.

Avatar

Avatar
Validate 1
Level 1
nandand81957514
Level 1

Likes

2 likes

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 1
nandand81957514
Level 1

Likes

2 likes

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
Applaud 5
View profile
nandand81957514
Level 1

15-11-2017

If you change allowProxy to false under /libs...would it not get overwritten once you install an AEM Update/CFP or SP ?

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

14-11-2017

Customer Care Link:- https://daycare.day.com/public/contact.html

If you are not to register the above then email at :- cuscare@adobe.com and request the access.

Avatar

Avatar
Give Back 3
Level 2
ananta99
Level 2

Likes

2 likes

Total Posts

18 posts

Correct reply

1 solution
Top badges earned
Give Back 3
Validate 1
Give Back
Boost 1
Applaud 5
View profile

Avatar
Give Back 3
Level 2
ananta99
Level 2

Likes

2 likes

Total Posts

18 posts

Correct reply

1 solution
Top badges earned
Give Back 3
Validate 1
Give Back
Boost 1
Applaud 5
View profile
ananta99
Level 2

14-11-2017

victor.toledo.3share​ - Thank you very much.

Avatar

Avatar
Give Back 3
Level 2
ananta99
Level 2

Likes

2 likes

Total Posts

18 posts

Correct reply

1 solution
Top badges earned
Give Back 3
Validate 1
Give Back
Boost 1
Applaud 5
View profile

Avatar
Give Back 3
Level 2
ananta99
Level 2

Likes

2 likes

Total Posts

18 posts

Correct reply

1 solution
Top badges earned
Give Back 3
Validate 1
Give Back
Boost 1
Applaud 5
View profile
ananta99
Level 2

14-11-2017

Hi @victor.toledo.3share

Could you please share the detail steps you did to get rid of those warnings?

The paths you mentioned in the previous comment don't exist for me when I go to crx/de.

Thanks,

Ananta

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

14-11-2017

We added those instructions to the featured content at the beginning of this forum. See the Post by Peter Nash.

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

14-11-2017

@kautuksahni how can i create a support ticket?

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

13-11-2017

Not yet. I tried some fixes, but it seems that they do not work

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

06-11-2017

Avatar

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
victor_toledo_3
Level 2

Likes

14 likes

Total Posts

39 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
victor_toledo_3
Level 2

06-11-2017

Yes, i have ACS Commons 3.9.0

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

05-11-2017

Based on the previous thread [1] it seems to be Issue with ACS. Do you have ACS Commons installed?

Refer to the workaround provided:-

[1] continuous Warning in authoring ui

PS:- Linking similar issue: com.day.cq.wcm.webservicesupport.impl.ConfigurationManagerImpl Resource with path /etc/cloudservices... and Re: continuous error with ajax call to .2.html when hovering over authoring ui